Intereting Posts
Не удается смонтировать USB: «Не авторизовано» Как переместить окно между мониторами с помощью Gnome Shell? Compiz CCSM разбил запускающую панель и оконную панель на Ubuntu 14LTS? проблема поиска слова в pdf-файле с помощью «Document Viewer»? Супер корову? Не удалось создать пользовательскую схему URI на Ubuntu Как я могу увидеть, где Ubuntu установлен на моем жестком диске? Каков наилучший способ управления музыкой на моем ПК с моего iphone или Android? Каковы риски / преимущества работы с основным ядром? Листинг и удаление альбомов со слишком маленьким битрейтом Запуск различных java на основе параметра командной строки Могу ли я попробовать Ubuntu, не затрагивая ни один из моих существующих файлов? Не удалось запустить VMware – Не удалось создать vmnet Какая лучшая операционная система для старого компьютера? Linux Как отключить кнопку «Супер», чтобы она не отображала окно поиска?

Как установить последнюю версию Mono и MonoDevelop на Ubuntu?

Я пытаюсь установить в моей системе последнюю версию среды Mono и MonoDevelop. Вчера я пробовал установку на Ubuntu (14.04 LTS) и на Debian (V8.2) сегодня. Обе установки завершились с ошибкой. Я использовал это официальное руководство по установке.

http://www.mono-project.com/docs/getting-started/install/linux/#debian-ubuntu-and-derivatives

Я выполнил эти команды.

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF echo "deb http://download.mono-project.com/repo/debian wheezy main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list sudo apt-get update 

Произошла следующая ошибка.

 root@debian:/home/administrator# apt-get install mono-complete Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: mono-complete : Depends: mono-devel (= 4.2.1.102-0xamarin1) but it is not going to be installed Depends: mono-4.0-service (= 4.2.1.102-0xamarin1) but it is not going to be installed Depends: libmono-cil-dev (= 4.2.1.102-0xamarin1) but it is not going to be installed E: Unable to correct problems, you have held broken packages. 

Кто-нибудь знает решение?

Большое спасибо, Jordy

Попробуйте следующее:

 sudo apt-get install libjpeg62-turbo 

И если вы получите:

 Reading package lists... Done Building dependency tree Reading state information... Done Package libjpeg62-turbo is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'libjpeg62-turbo' has no installation candidate 

Предполагая, что вы находитесь в 64-битной системе ARCH, вы можете получить этот пакет через:

 wget http://ftp.br.debian.org/debian/pool/main/libj/libjpeg-turbo/libjpeg62-turbo_1.4.1-2_amd64.deb 

Установите deb:

 sudo dpkg --install --recursive --auto-deconfigure libjpeg62-turbo_1.4.1-2_amd64.deb 

Теперь установите mono / monodevelop:

 sudo apt-get install mono-devel sudo apt-get install monodevelop 

Re: http://sushihangover.github.io/mono-ubuntu-broken/ (отказ от ответственности, это мой блог)