Не удается установить Rails на Ubuntu 10.10

Я хочу попытаться установить Rails с помощью этого руководства – http://ryanbigg.com/2010/12/ubuntu-ruby-rvm-rails-and-you/

Моя последняя команда:

gem install rails -v 3.2.3 

Теперь, когда я бегу

  rails new project 

дает мне ошибки:

  /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require': libcrypto.so.1.0.0: cannot open shared object file: No such file or directory - /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/i686-linux/digest/sha1.so (LoadError) from /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require' from /home/denys/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/definition.rb:1:in `' from /home/denys/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler.rb:144:in `definition' from /home/denys/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler.rb:112:in `setup' from /home/denys/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/setup.rb:7:in `' from /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in `require' from /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in `rescue in require' from /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:35:in `require' from /home/denys/Desktop/pull/printitgreen/printitgreen/config/boot.rb:6:in `' from /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require' from /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require' from script/rails:5:in `' denys@denys-N68S3:~/Desktop/pull/printitgreen/printitgreen/script$ rails -v /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems /custom_require.rb:36:in `require': libcrypto.so.1.0.0: cannot open shared object file: No such file or directory - /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1 /i686-linux/digest/sha1.so (LoadError) from /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems /custom_require.rb:36:in `require' from /home/denys/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler /definition.rb:1:in `' from /home/denys/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler.rb:144:in `definition' from /home/denys/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler.rb:112:in `setup' from /home/denys/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/setup.rb:7:in `' from /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in `require' from /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in `rescue in require' from /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:35:in `require' from /home/denys/Desktop/pull/printitgreen/printitgreen/config/boot.rb:6:in `' from /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require' from /home/denys/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require' from script/rails:5:in `' --------------------------- 

Больше информации:

  denys@denys-N68S3:~/Desktop$ rvm list rvm rubies ruby-1.9.2-p320 [ i686 ] =* ruby-1.9.3-p194 [ i686 ] # => - current # =* - current && default # * - default 

    Однако я не уверен в этой проблеме, но это мне помогло.

    похоже, что ваш ruby ​​не был скомпилирован с поддержкой openssl.

    установить openssl-dev и переустановить / перекомпилировать ruby

    Выполняете ли вы команды apt-get, перечисленные в учебнике?

    Пытаться:

    sudo apt-get install libssl-dev