ОШИБКА: версия декодера libvpx должна быть> = 0.9.1

Heyo! Я пытаюсь установить ffmpeg на свой сервер, используя следующий учебник: https://ffmpeg.org/trac/ffmpeg/wiki/UbuntuCompilationGuideLucid Когда я добираюсь до части ffmpeg и запускаю команду ./configure, она дает следующую ошибку:

ERROR: libvpx decoder version must be >=0.9.1 

Я должен упомянуть, что у моего сервера Ubunto 10.10 64bit. Я новичок в Linux, поэтому, пожалуйста, примите это во внимание 🙂 Большое спасибо!

После решения LordNeckBeard после checkinstall я получил следующую ошибку:

 root@348588:~/libvpx# sudo checkinstall --pkgname=libvpx --pkgversion="$(date +%Y%m%d%H%M)-git" --backup=no--default --deldoc=yes checkinstall 1.6.2, Copyright 2009 Felipe Eduardo Sanchez Diaz Duran This software is released under the GNU GPL. no--default is an invalid value for --backup Use --help or -h to get more information 

Это означает, что libvpx не установлен правильно или у вас установлена ​​старая версия libvpx версии <0.9.1.

Ваш первый шаг – проверить, установил ли libvpx. Если вы установили следующее:

 $ dpkg -s libvpx | grep Status Status: install ok installed 

Если он не установлен:

 $ dpkg -s libvpx | grep Status Status: unknown ok not-installed 

Возможно, было бы неплохо удалить libvpx-dev если он присутствует, поэтому он не мешает ffmpeg обнаруживать ваш скомпилированный libvpx:

 sudo apt-get remove libvpx-dev 

Затем попробуйте установить libvpx еще раз:

 cd ~/libvpx make clean git pull ./configure make sudo checkinstall --pkgname=libvpx --pkgversion="$(date +%Y%m%d%H%M)-git" --backup=no --default --deldoc=yes 

Теперь попробуйте ffmpeg еще раз:

 cd ~/ffmpeg make distclean git pull 

Затем продолжайте руководство, как показано, начиная с строки ffmpeg ./configure .

посмотрите на хвост ./ffmpeg/config.log, чтобы проверить, что именно проблема, и исключить любую двусмысленность в сообщении об ошибке.

если это ошибка версии на vpx, вы можете вручную перейти на git и получить новую версию vpx, зарегистрированную в папке vpx.

см. здесь для различных новых тегов, которые вы можете проверить с помощью git.

затем перезапустите шаги config / make / install в папке vpx в соответствии с вашим исходным процессом

перезапустите ffmpeg / configure, чтобы разрешить ошибку orig