Пакет Buildozer доступен для установки или обновления

Это дисплей, который я получаю при создании своего приложения для Android. пожалуйста помоги!

Пакеты, доступные для установки или обновления: 3

id: 1 or "tools" Type: Tool Desc: Android SDK Tools, revision 22.6.2 ---------- id: 2 or "platform-tools" Type: PlatformTool Desc: Android SDK Platform-tools, revision 19.0.1 ---------- id: 3 or "addon-google_gdk-google-19" Type: Addon Desc: Glass Development Kit Preview, Android API 19, revision 8 By Google Inc. Preview of the Glass Development Kit Requires SDK Platform Android API 19 

Traceback (последний последний вызов):

 File "/usr/local/bin/buildozer", line 9, in  load_entry_point('buildozer==0.16-dev', 'console_scripts', 'buildozer')() File "/usr/local/lib/python3.4/dist-packages/buildozer-0.16_dev-py3.4.egg/buildozer/scripts/client.py", line 13, in main Buildozer().run_command(sys.argv[1:]) File "/usr/local/lib/python3.4/dist-packages/buildozer-0.16_dev-py3.4.egg/buildozer/__init__.py", line 959, in run_command self.target.run_commands(args) File "/usr/local/lib/python3.4/dist-packages/buildozer-0.16_dev-py3.4.egg/buildozer/target.py", line 85, in run_commands func(args) File "/usr/local/lib/python3.4/dist-packages/buildozer-0.16_dev-py3.4.egg/buildozer/target.py", line 95, in cmd_debug self.buildozer.prepare_for_build() File "/usr/local/lib/python3.4/dist-packages/buildozer-0.16_dev-py3.4.egg/buildozer/__init__.py", line 157, in prepare_for_build self.target.install_platform() File "/usr/local/lib/python3.4/dist-packages/buildozer-0.16_dev-py3.4.egg/buildozer/targets/android.py", line 383, in install_platform self._install_android_packages() File "/usr/local/lib/python3.4/dist-packages/buildozer-0.16_dev-py3.4.egg/buildozer/targets/android.py", line 339, in _install_android_packages self._android_update_sdk('tools,platform-tools') File "/usr/local/lib/python3.4/dist-packages/buildozer-0.16_dev-py3.4.egg/buildozer/targets/android.py", line 303, in _android_update_sdk from buildozer.libs.pexpect import EOF File "/usr/local/lib/python3.4/dist-packages/buildozer-0.16_dev-py3.4.egg/buildozer/libs/pexpect.py", line 81 except ImportError, e: ^ SyntaxError: invalid syntax 

я вступил в ту же проблему. На самом деле buildozer, похоже, делает обновление, просто не говоря, что он это делает.

Так что просто подождите 🙂

Python 3 не поддерживает, except Foo, bar но только except Foo as bar . Таким образом, buildozer похоже, содержит библиотеку, которая несовместима с Python 3.

Лучше свяжитесь с разработчиком buildozer – это будет намного полезнее как вам, так и этому инструменту, чем размещать об этом на SO.