установка расширения PECL id3 на Ubuntu

Я пробовал это с недели теперь все еще не смог найти ответ для этого, когда я пытаюсь использовать sudo pecl install id3 эта ошибка возникает

 downloading id3-0.2.tgz ... Starting to download id3-0.2.tgz (20,693 bytes) .....done: 20,693 bytes 4 source files, building running: phpize Cannot find config.m4. Make sure that you run '/usr/bin/phpize' in the top level source directory of the module If the command failed with 'phpize: not found' then you need to install php5-dev packageYou can do it by running 'apt-get install php5-dev' as a root userERROR: `phpize' failed 

пожалуйста помоги !!! Я уже установил php5-dev.

http://php.net/manual/en/id3.installation.php

Сначала вам нужно скачать id3, используя:

 pecl download id3-alpha tar -zxvf id3*.tgz vim id3.c 

Необходимо изменить строку 196: function_entry id3_functions [] = {

в

zend_function_entry id3_functions [] = {

 phpize ./configure make make test make install 

Затем добавьте id3.so в файл php.ini и перезапустите apache

Это известная проблема, см. https://bugs.php.net/bug.php?id=58650

Проверено, проверено, подтверждено обходное решение:

 pear update-channels pecl install --force id3 cd /build/buildd/php*/pear-build-download tar -zxvf id3*.tgz cd id3*/ phpize ./configure make make test make install 

Добавьте расширение id3.so в файл php.ini :

 nano /etc/php5/apache2/php.ini 

лайк:

 extension=id3.so 

в раздел « Dynamic Extensions ».

Затем перезапустите apache чтобы можно было загрузить новую конфигурацию:

 service apache2 restart 

убедитесь, что все прошло хорошо, и ошибок нет, проверяя файл журнала ошибок apache:

 tail -25 /var/log/apache2/error.log 

Успех должен иметь аналогичный результат:

 [notice] caught SIGTERM, shutting down [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.9 with Suhosin-Patch configured -- resuming normal operations