Установка PIP Python 3.6.3 Ubuntu 16.04 Zlib недоступен, но он установлен

Я пытаюсь следовать этому руководству по установке Python 3.6.3 и PIP с виртуальными средами, но когда я получаю sudo python3.6 get-pip.py я получаю ошибку

 Traceback (most recent call last): File "get-pip.py", line 20061, in  main() File "get-pip.py", line 194, in main bootstrap(tmpdir=tmpdir) File "get-pip.py", line 82, in bootstrap import pip zipimport.ZipImportError: can't decompress data; zlib not available 

но у меня установлен zlib1g-dev и не знаю, как исправить эту проблему. Я много гугл и пытался переустановить, но не добился успеха.

Извините, что начал новый вопрос, но мне не хватало кармы, чтобы прокомментировать ее. Любая помощь будет принята с благодарностью.

Обновление: я закончил установку всего из исходного кода вместо использования каких-либо пакетов и, похоже, работает. Я не смог решить проблему, но нашел альтернативный способ заставить все работать.

    Для работы протокола Python необходимо связать с библиотекой zlib, когда установлен сам Python. Похоже, что либо zlib не был установлен при установке Python, либо, по крайней мере, что установщик Python не смог его найти. Чтобы помочь ему, вы можете выполнить следующие действия перед установкой Python. В синтаксисе bash,

     zlib_lib="/usr/lib32" zlib_inc="/usr/include" export CPPFLAGS="-I${zlib_inc} ${CPPFLAGS}" export LD_LIBRARY_PATH="${zlib_lib}:${LD_LIBRARY_PATH}" export LDFLAGS="-L${zlib_lib} -Wl,-rpath=${zlib_lib} ${LDFLAGS}" в zlib_lib="/usr/lib32" zlib_inc="/usr/include" export CPPFLAGS="-I${zlib_inc} ${CPPFLAGS}" export LD_LIBRARY_PATH="${zlib_lib}:${LD_LIBRARY_PATH}" export LDFLAGS="-L${zlib_lib} -Wl,-rpath=${zlib_lib} ${LDFLAGS}" 

    Здесь я предположил, что zlib установлен в /usr/lib32 и /usr/include/ . Чтобы проверить это, libz.so.1 файл libz.so.1 каталоге «lib» и zlib.h каталоге «inc». Если вы найдете их где-то еще, просто измените zlib_lib и zlib_inc соответственно.

    Если у вас установлены разные версии Python, скорее всего, установка находится на другой версии. например. У меня есть pyperclip в версии 3.6.3 32bit, но я не получаю доступ к ней в 3.6.3 64bit или 3.7.2dev.