Форсировать компиляцию с qt4, даже если qt5 установлен

Я на Ubuntu 14.04 и у меня установлены как qt4, так и qt5 (из репозиториев). Я думал, что могу переключаться между зданием с qt5 на построение с qt4 просто с помощью

sudo apt-get install qt4-default 

Но программа по-прежнему построена с Qt5 и дает ошибку, потому что она поддерживает только Qt4.

Я проверил версию qmake и после того, как qt4-default установлен, он дает

 $ qmake --version QMake version 2.01a Using Qt version 4.8.6 in /usr/lib/x86_64-linux-gnu 

Я создаю CMake в случае, если это полезно. Кроме того, если я это сделаю

 sudo apt-get remove qtbase5-dev 

то, наконец, он строит с qt4.

EDIT: я не использую Qt Creator и предпочел бы решение командной строки

Вам нужно будет поместить это в ваш CMakeLists.txt:

 find_package(Qt4 REQUIRED) ... include_directories(${QT_INCLUDES}) target_link_libraries(main ${QT_QTCORE_LIBRARY})