Как установить более раннюю версию ядра 2.6.37?

У меня нетбук Sony VAIO P и по нескольким вопросам (драйвер графики, аудио драйвер и управление питанием), я хочу установить более старую версию ядра Linux на Ubuntu 11.10 (на самом деле ее Xubuntu), которая кажется намного более подходящей.

Поэтому я искал ядра Ubuntu и нашел эту ссылку, которая включает все версии ядра Linux, распространяемые Ubuntu. Я ищу версию до 2.6.38 (чтобы избежать известной проблемы с управлением питанием) и, конечно, решить многие проблемы с драйверами!

  1. Я думаю, мой лучший выбор – 2.6.37, но есть несколько ядер 2.6.37.xx! Может ли кто-нибудь указать мне на правильный выбор?

  2. В каждой папке (например, этой ) есть несколько пакетов DEB. Какие пакеты я должен установить? (Примечание: у меня 32-битная система)

  3. Каков процесс установки? sudo dpkg -i *.deb ? Требуются ли эти мелкие или дополнительные шаги?

Благодарю.

сначала предупреждение

Изменение ядра не следует воспринимать легкомысленно – вы можете оставить серьезные проблемы с графикой и другие проблемы – и даже сценарии без загрузки.

Целесообразно создать образ диска с помощью хорошего инструмента для создания изображений, такого как Clonezilla, прежде чем вы начнете.

ядра ядра ядра ядра ubuntu

Ядра mainline построены с использованием более старой инструментальной цепочки, чем исходные ядра ubuntu. Возможно, лучше рассмотреть вопрос о загрузке ядер Ubuntu из определенных версий Ubuntu

Например – 2.6.38 для Natty, 2.6.35 для Maverick и 2.6.32 для Lucid.

Однако вы можете с нетерпением ждать v3.2, который будет использоваться в Precise – некоторые из них сообщили о хороших проблемах с управлением питанием с этим ядром, а также с последними драйверами.

Здесь есть аналогичный вопрос, который даст вам дополнительную информацию: как понизить ядро ​​на 11.10

Предполагая, что ваша основная проблема – управление питанием, перед тем, как вы захотите изменить свое ядро ​​- подумайте над установкой Jupiter – это отличный инструмент управления энергопотреблением.

установка с магистрали

Если вы должны скачать с главной линии, то полные инструкции находятся в вики сообщества . В сумме 32-битные или 64-битные пакеты deb для заголовков и общего изображения вместе с общим пакетом «all» deb.

Все пакеты .deb могут быть установлены с тем же синтаксисом:

 sudo dpkg -i [package_name].deb 

Если вы хотите использовать 2.6.37 – тогда просто используйте последнюю версию 2.6.37.x. Примечание. Ни одно из этих ядер не будет получать обновления для системы безопасности – вам придется их исправлять самостоятельно.

Если вы используете проприетарные драйверы (например, nvidia или fglrx), вам придется переустановить эти драйверы. Возможно, было бы целесообразно переименовать файл /etc/X11/xorg.conf перед загрузкой.

Вместо того, чтобы возвращаться назад, почему бы не попробовать новое ядро ​​и посмотреть, устраняют ли эти проблемы проблемы, с которыми вы, похоже, сталкиваетесь и в то же время обновляете свою систему до более стабильной и свободной от ошибок версии?

Попробуй это:

http://www.ubuntugeek.com/how-to-install-linux-kernel-3-5-rc-in-ubuntu-using-ppa.html

Мне пришлось установить еще более старое ядро ​​(2.6.32.21-generic) для модулей запаса для работы с настраиваемым ядром. VBoot выпускает свой модуль, встроенный в ядро, и мне приходилось сопоставлять версии, чтобы заставить мое другое оборудование работать.

Как таковой, я думал, что объясню, как получить прекращенные ядра вручную из http://old-releases.ubuntu.com/ubuntu/

  1. В приведенных ниже шагах замените xxxx-xx своей версией ядра и amd64 на ваш тип процессора. Обратите внимание, что это относится к общему ядру и не использует дополнительные функции, такие как PAE.

  2. Перейдите в http://old-releases.ubuntu.com/ubuntu/pool/main/l/linux/ (я считаю, что в этом списке перечислены большинство, если не все старые пакеты ядра)

  3. На странице CTRL + F найдите headers-xxxx-xx-generic и загрузите
    1. linux-headers-xxxx-xx-generic_x.x.xx-xx.yy_ amd64 .deb
    2. linux-headers-xxxx-xx-generic_x.x.xx-xx.yy_ all .deb
  4. На странице CTRL + F найдите image-xxxx-xx-generic и загрузите

    1. linux-image-2.6.32-21-generic_2.6.32-21.32_ amd64 .deb
  5. Поместите все эти пакеты в одну папку и из этой папки ( cd в нее) запустите

    1. sudo dpkg -i *.deb