Ошибка коррупции библиотеки во время обновления apt-get

Я не могу установить какой-либо пакет. Кажется, команда apt-get update должна быть запущена, но она вызывает некоторые ошибки:

 $ sudo apt-get update Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB] Hit:2 http://ve.archive.ubuntu.com/ubuntu xenial InRelease Hit:3 http://ve.archive.ubuntu.com/ubuntu xenial-updates InRelease Hit:4 http://ve.archive.ubuntu.com/ubuntu xenial-backports InRelease Fetched 102 kB in 23s (4337 B/s) *** Error in `appstreamcli': double free or corruption (fasttop): 0x000000000210f4b0 *** ======= Backtrace: ========= /lib/x86_64-linux-gnu/libc.so.6(+0x777e5)[0x7fac8d8317e5] [...] Aborted (core dumped) Reading package lists... Done E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh > /dev/null; fi' E: Sub-process returned an error code 

Полный вывод output.txt

Это сработало для меня (отсюда https://forum.siduction.org/index.php?topic=6174.0 ):

 sudo apt-get purge libappstream3 
 sudo apt install --reinstall libappstream3 

может исправить это.

В моем случае чистка или переустановка не помогли.

Однако удаление записи apt.conf.d решило проблему для меня.

 Friday 25 August 22:17:45 AEST 2017 LSB Version: core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:printing-9.20160110ubuntu0.2-amd64:printing-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch Distributor ID: Ubuntu Description: Ubuntu 16.04.3 LTS Release: 16.04 Codename: xenial 

Я выполнил следующие команды, чтобы избавиться от ошибки:

 sudo apt-get purge libappstream2 sudo rm /etc/apt/apt.conf.d/50appstream