ПРЕДУПРЕЖДЕНИЕ. Следующие пакеты не могут быть аутентифицированы. `apt-key update` не работает

Я пытаюсь установить bitcoind, просто сделав sudo apt-get install bitcoind , но я получаю эту ошибку, говоря, что следующие пакеты не могут быть аутентифицированы:

 libdb5.1++ libcrypto++9 bitcoind 

Я могу просто установить их без проверки подлинности, но поскольку эта программа может обрабатывать деньги, я бы хотел, чтобы они были правильными. Поэтому я нашел это решение здесь на AskUbuntu, которое предлагает сделать следующее:

 $ sudo apt-key update $ sudo apt-get update 

После первой команды он перечисляет четыре ключа, из которых он говорит, что все остаются неизменными. Вторая команда просто выполняет обычную, но заканчивается сообщением о наличии ошибки GPG. После некоторого blabla он сообщает, что следующие подписи являются недействительными (свободно переводятся с голландского):

 BADSIG 16126D3A3E5C1192 Ubuntu Extras Archive Automatic Signing Key <ftpmaster@ubuntu.com> BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com> 

И следующие подписи не могут быть проверены, поскольку открытый ключ недоступен:

 NO_PUBKEY 1F968B3903D886E7 

И следующие сугуляции были недействительными:

 BADSIG E585066A30C18A2B Opera Software Archive Automatic Signing Key 2013 <packager@opera.com> 

И что получить материал по следующему адресу не удалось:

  http://extras.ubuntu.com/ubuntu/dists/precise/Release 

Кто-нибудь знает, что я могу сделать, чтобы решить эту проблему?