Пакетные зависимости не могут быть разрешены

когда я пытаюсь открыть файл avidio, например расширение .mkv, с помощью mplayer, он требует некоторого мультимедийного плагина, такого как gstreamer, и недавно установленного Ubuntu 12.01

и когда я скажу ему, чтобы установить их, что Ошибка появляется мне:

Эта ошибка может быть вызвана необходимыми дополнительными пакетами программного обеспечения, которые отсутствуют или не могут быть установлены. Кроме того, может возникнуть конфликт между программными пакетами, которые не могут быть установлены одновременно.

The following packages have unmet dependencies: gstreamer0.10-ffmpeg: Depends: libavcodec-extra-53 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed Depends: libavformat-extra-53 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed Depends: libavutil-extra-51 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed Depends: libc6 (>= 2.7) but 2.15-0ubuntu10.2 is to be installed Depends: libglib2.0-0 (>= 2.31.2) but 2.32.3-0ubuntu1 is to be installed Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed Depends: libpostproc-extra-52 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed Depends: libswscale-extra-2 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed gstreamer0.10-ffmpeg:i386: Depends: libavcodec-extra-53 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed Depends: libavformat-extra-53 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed Depends: libavutil-extra-51 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed Depends: libc6 (>= 2.7) but 2.15-0ubuntu10.2 is to be installed Depends: libglib2.0-0 (>= 2.31.2) but 2.32.3-0ubuntu1 is to be installed Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed Depends: libpostproc-extra-52 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed Depends: libswscale-extra-2 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed 

и я искал и обнаружил, что большинство решений

 sudo apt-get clean sudo apt-get autoclean sudo apt-get install -f 

и я попробовал их, и ничего не случилось

и содержание моих sources.list

 # deb cdrom:[Ubuntu 12.04.1 LTS _Precise Pangolin_ - Release amd64 (20120823.1)]/ dists/precise/main/binary-i386/ # deb cdrom:[Ubuntu 12.04.1 LTS _Precise Pangolin_ - Release amd64 (20120823.1)]/ dists/precise/restricted/binary-i386/ # deb cdrom:[Ubuntu 12.04.1 LTS _Precise Pangolin_ - Release amd64 (20120823.1)]/ precise main restricted # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to # newer versions of the distribution. deb http://eg.archive.ubuntu.com/ubuntu/ precise main restricted deb-src http://eg.archive.ubuntu.com/ubuntu/ precise main restricted ## Major bug fix updates produced after the final release of the ## distribution. deb http://eg.archive.ubuntu.com/ubuntu/ precise-updates main restricted deb-src http://eg.archive.ubuntu.com/ubuntu/ precise-updates main restricted ## NB software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu ## team. Also, please note that software in universe WILL NOT receive any ## review or updates from the Ubuntu security team. deb http://eg.archive.ubuntu.com/ubuntu/ precise universe deb-src http://eg.archive.ubuntu.com/ubuntu/ precise universe deb http://eg.archive.ubuntu.com/ubuntu/ precise-updates universe deb-src http://eg.archive.ubuntu.com/ubuntu/ precise-updates universe ## NB software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu ## team, and may not be under a free licence. Please satisfy yourself as to ## your rights to use the software. Also, please note that software in ## multiverse WILL NOT receive any review or updates from the Ubuntu ## security team. deb http://eg.archive.ubuntu.com/ubuntu/ precise multiverse deb-src http://eg.archive.ubuntu.com/ubuntu/ precise multiverse deb http://eg.archive.ubuntu.com/ubuntu/ precise-updates multiverse deb-src http://eg.archive.ubuntu.com/ubuntu/ precise-updates multiverse ## NB software from this repository may not have been tested as ## extensively as that contained in the main release, although it includes ## newer versions of some applications which may provide useful features. ## Also, please note that software in backports WILL NOT receive any review ## or updates from the Ubuntu security team. deb http://eg.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse deb-src http://eg.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse deb http://security.ubuntu.com/ubuntu precise-security main restricted deb-src http://security.ubuntu.com/ubuntu precise-security main restricted deb http://security.ubuntu.com/ubuntu precise-security universe deb-src http://security.ubuntu.com/ubuntu precise-security universe deb http://security.ubuntu.com/ubuntu precise-security multiverse deb-src http://security.ubuntu.com/ubuntu precise-security multiverse ## Uncomment the following two lines to add software from Canonical's ## 'partner' repository. ## This software is not part of Ubuntu, but is offered by Canonical and the ## respective vendors as a service to Ubuntu users. # deb http://archive.canonical.com/ubuntu precise partner # deb-src http://archive.canonical.com/ubuntu precise partner ## This software is not part of Ubuntu, but is offered by third-party ## developers who want to ship their latest software. deb http://extras.ubuntu.com/ubuntu precise main deb-src http://extras.ubuntu.com/ubuntu precise main 

поэтому вопрос в том, как установить этот плагин, чтобы вы могли смотреть мои фильмы и видео

Глядя на ваши сообщения об ошибках, я предполагаю, что вы либо установили пакеты, которые являются более новой версией, чем стандартным репо (я мог бы этого не делать), либо установленные пакеты, которые зависят от более старых версий пакетов (скорее всего), и он не обновляется для последних (таким образом, требуются более старые версии).

Я предлагаю вам сделать это: (в большинстве случаев это работает)

  1. Установите aptitude с помощью команды sudo apt-get install aptitude

  2. Попробуйте установить пакет, который вы хотите установить с помощью команды

     sudo aptitude install <package-name> 
  3. Aptitude покажет вам ошибку и представит вам возможное (лучшее) решение. Вам будет предложено выбрать один из 3 вариантов с сообщением типа

     Accept this solution? [Y/n/q/?] 

    Если вы видите, что нужный пакет не указан в списке (будет), просто нажмите n, чтобы aptitude предоставила вам следующее лучшее решение. После нескольких пробных версий (если вам повезет) вы увидите, что ваши нужные пакеты находятся в списке установки, а пакеты, вызывающие проблемы с зависимостью, будут отображаться в списке понижающих версий . На этом этапе нажмите Y, чтобы принять решение. Пакеты будут понижены, чтобы удовлетворить запрос на установку.

Мне жаль, что я не могу дать вам демо-версию, подобную этой , но вы можете проверить эту страницу, чтобы увидеть некоторые ее действия.

Очистите кеш и загрузите пакеты sudo apt-get clean sudo apt-get autoclean

Попробуйте с sudo apt-get install -f, я тоже получаю эти ошибки.

Перейдите в программный центр ubuntu >> Изменить >> Источники программного обеспечения >> Загрузить с >> Выбрать США После этого перезагрузите компьютер, перейдите в программный центр и введите вино и установите его

sudo apt-get update для обновления списка пакетов sudo apt-get autoclean для очистки любых частичных пакетов sudo apt-get clean для очистки apt-кеша sudo apt-get autoremove очистит любые ненужные зависимости

Откройте терминал и скопируйте и вставьте весь этот код:

 sudo apt-get clean && sudo apt-get autoclean && sudo apt-get autoremove && sudo apt-get update && sudo apt-get upgrade && sudo add-apt-repository ppa:ubuntu-wine/ppa && sudo apt-get update && sudo apt-get install wine1.5 

ЕСЛИ ЭТО НЕ РАБОТАЕТ, ПОПРОБУЙТЕ ЭТО: Я предлагаю вам сделать следующее: (в большинстве случаев это работает)

Установите aptitude с помощью команды sudo apt-get install aptitude

Попробуйте установить пакет, который вы хотите установить с помощью команды

 sudo aptitude install <package-name> 

Aptitude покажет вам ошибку и представит вам возможное (лучшее) решение. Вам будет предложено выбрать один из 3 вариантов с сообщением типа

 Accept this solution? [Y/n/q/?] 

Если вы видите, что нужный пакет не указан в списке (будет), просто нажмите n, чтобы aptitude предоставила вам следующее лучшее решение. После нескольких пробных версий (если вам повезет) вы увидите, что ваши нужные пакеты находятся в списке установки, а пакеты, вызывающие проблемы с зависимостью, будут отображаться в списке понижающих версий. На этом этапе нажмите Y, чтобы принять решение. Пакеты будут понижены, чтобы удовлетворить запрос на установку.

Мне жаль, что я не могу дать вам демо-версию, подобную этой, но вы можете проверить эту страницу, чтобы увидеть некоторые ее действия.

Если при этом вы можете определить сломанный пакет, эта команда очень сильно удалит его:

sudo dpkg –remove -force –force-remove-reinstreq packagename Замените «packagename» на реальное имя, конечно.

У меня была такая же проблема, как и вы. Вам просто нужно быть осторожным и выбирать кодеки для вашей архитектуры устройства. Для этого заставьте окно рассказывать о кодеках большой, чтобы вы могли видеть полное имя пакетов. Если у вас 32-разрядный процессор, выберите те, у кого i386 в конце. Но, если у вас 64-битный процессор, выберите те, у кого нет i386 в конце.