Как защитить себя от переполнения буфера libpng в ошибке безопасности png_set_PLTE?

На сегодняшний день существует ошибка безопасности, влияющая на библиотеку libpng. Суровость в том, что библиотека используется огромным количеством проектов: браузерами, музыкальными проигрывателями, играми, Linux Distro.

Другим фактором является то, что некоторые используют модифицированную версию libpng, на мой вопрос, влияет ли Ubuntu на это? И если да, то как мне защитить себя, пока они не исправят эту ошибку?

Справка: