Intereting Posts
который PPA имеет самую последнюю версию git для 12.04? ppa: git-core / ppa устарела Как долго будет поддерживаться Ubuntu 13.04? Изменение пути установки по умолчанию к вновь установленному жесткому диску Как удалить Telegram? Есть ли способ узнать, какая кодировка используется для имени и содержимого файла? Как открыть защищенный паролем файл Excel в ubuntu 12.04? Как конвертировать видео с ffmpeg в формат dnxhd с целью использования его в cinelerra? Как уменьшить или увеличить количество рабочих областей в Unity? Не удалось инициализировать графический процессор NVIDIA с Nvidia 660m и шмелем Как кешировать pphp-кодовую фразу с морским коньком (14.04) Случайный ввод символов начинается после ввода во время коротких зависаний Переместить панель уведомлений индикатора вверх в крайний правый угол в сеансе рабочего стола XFCE chmod только определенные типы mime Не могу установить libsdl2-dev или cmake glfw .. (проблема libxinerama-dev) Как установить «Сообщать мне о новой версии Ubuntu» в командной строке

Вопросы по архитектуре

Итак, я старался как можно больше узнать о Linux-операционных системах, и что-то в настоящее время меня пугает.

uname -a

Linux L655 3.5.0-27-generic #46-Ubuntu SMP Mon Mar 25 19:58:17 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux 

Итак, моя система – x86_64, значит, она 32-битная, правильно? Итак, поскольку это 32 бит, я могу установить только 32-разрядные программы. Моя путаница в том, что когда я устанавливал плагин google talk, i386 .deb не работал, и amd64. Зачем?

Кроме того, если я установлю программу с dkpg, узнают ли мои другие менеджеры пакетов (синаптик, программный центр и т. Д.)?

Благодарю.

Отвечая на ваши вопросы один за другим.

  • Итак, моя система – x86_64, значит, она 32-битная, правильно?

    Нет . x84_64 означает, что ваша система 64 бит.

    Для 32-битной машины вывод uname -a будет примерно таким:

 Linux discworld 2.6.38-8-generic # 42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 i686 i686 i386 GNU / Linux

Хотя, как и в вашем случае, выход для 64-битной машины будет выглядеть примерно так:

  Linux discworld 2.6.38-8-generic # 42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 x86_64 x86_64 x86_64 GNU / Linux
  • Моя путаница в том, что когда я устанавливал плагин google talk, i386 .deb не работал, и amd64. Зачем?

    Поскольку ваш компьютер имеет 64 бит, вы должны установить пакеты программного обеспечения, построенные для архитектуры с 64-разрядной архитектурой. Конечно, если такие пакеты недоступны, вы можете вернуться к 32-битным пакетам.

  • Кроме того, если я установлю программу с dkpg, узнают ли мои другие менеджеры пакетов (синаптик, программный центр и т. Д.)?

    Да, они будут.

    Однако вам необходимо убедиться, что источники в Ubuntu Software Center установлены правильно. Для этого:

    • Откройте программный центр Ubuntu .
    • Затем перейдите в « Редактирование» > « Источники программного обеспечения» .
    • На вкладке « Другое программное обеспечение » убедитесь, что отмечены следующие отметки:

    введите описание изображения здесь