Как установить последнюю версию Evince?

У меня Ubuntu 12.04 с Evince 3.4.0. В этой версии Evince есть некоторые ошибки (в частности, демонстрирующие шаблоны), которые исправлены в версии 3.8.0. Кто-нибудь знает, есть ли какой-нибудь репозиторий, который будет обновляться? Я бы предпочел этот вариант (репозиторий), но если этого не сделать, я бы принял также ручную установку обновленной версии.

У меня был Evince 3.6.1. Как я модернизировал, я просто нажимаю Ctrl + Alt + T на клавиатуре, чтобы открыть терминал. Когда он откроется, запустите следующие команды:

sudo add-apt-repository ppa:gnome3-team/gnome3 sudo apt-get update sudo apt-get install evince 

Ниже представлены изображения до и после.

введите описание изображения здесь

введите описание изображения здесь

Имейте в виду, что текущий стабильный релиз – 3.6.1 .

Или используйте Synaptic. Если он не установлен, вы можете установить его, просто нажмите Ctrl + Alt + T на клавиатуре, чтобы открыть терминал. Когда он откроется, запустите следующие команды:

 sudo apt-get install synaptic 

редактировать

Evince за 12.04 больше не доступен в репо. его доступно только для 12.10 и 13.04. Чтобы получить его для других версий Ubuntu, проверьте здесь или здесь .

Вы можете попробовать репозиторий для запуска в GNOME3 .

Чтобы добавить его, откройте терминал и введите sudo apt-add-repository ppa:gnome3-team/gnome3 && sudo apt-get update . Но имейте в виду, что это обновит (если вы сделаете sudo apt-get upgrade ) все связанные с gnome пакеты.

Если вы попытаетесь установить через предварительно скомпилированные двоичные файлы, вы можете закончить свою систему из-за зависимостей.

Я в последнее время решал ту же проблему, и единственный способ решить ее – загрузить последнюю версию Evince (в моем случае это было 3.26) и скомпилировать ее вручную. К счастью, здесь есть руководство:

 ./configure --prefix=/usr --enable-compile-warnings=minimum --enable-introspection --disable-static && make 

В моем случае мне пришлось вручную установить 6 дополнительных пакетов (все в репо), чтобы успешно запустить команду .configure , но ничего Google не может помочь.

Поскольку это может быть полезно для пользователей Ubuntu, которые обречены использовать очень устаревшую версию Evince, и ради завершения, вот пакеты, которые мне пришлось установить в моем Linux Mint 18.2, чтобы скомпилировать:

libxml2-dev libsecret-1-dev libnautilus-extension-dev gobject-introspection-dev или libgirepository1.0-dev libpoppler-glib-dev itstool