Драйвер AMD Legacy в 12.10

Я сделал новую установку Ubuntu 12.10 на моем компьютере, у которого есть видеокарта AMD4890. Как я уже выяснил, устаревшие драйверы карт больше не работают с Xorg в 12.10. Я нашел много рекомендаций для этой процедуры: https://launchpad.net/~makson96/+archive/fglrx

Однако, когда я следую этому шаг за шагом, я не получаю никакого единства после перезагрузки.

Я бы использовал сторонний репозиторий, который предоставляет устаревший драйвер вместе с пониженным Xorg, который совместим с драйвером: http://www.unixmen.com/ubuntu-12-10-and-amd-catalyst-problem-solved/