Android-эмулятор работает очень медленно на ubuntu 17.04 по сравнению с windowsми 10

Я пробовал установить kvm из этой ссылки: https://help.ubuntu.com/community/KVM/Installation

Но даже после попытки этого эмулятор работает медленно, когда работает в режиме Software GLES 2.0, и когда я выбираю Hardware GLES 2.0 как Graphics, я не могу запустить avd. Он показывает начало avd в течение нескольких секунд, а затем после этого ничего не происходит. Что-то мне здесь не хватает?

    Таким образом, проблема в том, что Android SDK не может найти конфигурацию OpenGL и библиотеки. Google распространяет библиотеки OpenGL с SDK, но в Ubuntu этот конфиг не работает, потому что библиотека C ++ не может быть найдена, поэтому лучшее решение, которое я нашел, – это указать символьную ссылку на системные библиотеки, которые у вас уже есть на Ubuntu. В предыдущем тесте, которое я заставил вас выполнить силовую ситуацию из командной строки, но со следующими шагами вы можете иметь более постоянное и удобное решение, позволяющее запускать любой ускоритель аппаратного ускорения непосредственно из AVD UI.

    Прежде всего, ваши системные библиотеки находятся на этом пути Ubuntu:

    /usr/lib/x86_64-linux-gnu/ 

    Если нет libstdc++.so.6 файл присутствует внутри /usr/lib/x86_64-linux-gnu/ , установите его с помощью:

     sudo apt install libstdc++6 

    В вашей ситуации довольно очевидно, что у вас уже установлены правильные библиотеки, или эмуляторы не запускаются ни из командной строки, но я оставляю предыдущий шаг для людей, у которых в их системах нет правильной библиотеки.

    Итак, теперь нам нужно сказать Android SDK, что нам нужно использовать системные библиотеки. Для этого просто выполните следующее:

    Если есть файл libstdc++6 внутри ~/yoursdkpath/emulator/lib64/libstdc++/ do mv libstdc++6 libstdc++6.bak для его резервного копирования.

    Затем:

     ln -sf /usr/lib/x86_64-linux-gnu/libstdc++.so.6 ~/yoursdkpath/emulator/lib64/libstdc++/libstdc++.so.6 

    И все, перейдите на AVD и запустите любой эмулятор с настройкой Hardware GLES 2.0, и он будет работать.

    ВАЖНО: время от времени Google обновляет ваши эмуляторы. Если по какой-то причине вы заметите, что после обновления Google эмуляторы перестанут запускаться с AVD, повторите эти шаги, и все вернется в нормальное состояние.