«Apt-get» не находит пакеты на терминале

Я пытаюсь установить различные пакеты через Terminal, например, laptop-mode-tools , xserver-xorg-input-multitouch или xserver-xorg-input-mtrack , но он никогда не работает, потому что я получаю ошибку:

 Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package xserver-xorg-input-mtrack 

Обычно мне удалось установить этот материал через диспетчер пакетов Synaptic, но я не могу найти там драйвер «mtrack».

Любая идея, почему apt-get не работает? Я уже несколько раз запускаю sudo apt-get update .

EDIT: я запускаю Ubuntu 11.10 в MacBook Pro с двойной загрузкой (Leopard)

Благодаря BlueXrider, JasonD и CS мне удалось установить пакеты, которые я хотел. По-видимому, это была проблема с именами источников и пакетов. Это то, что я сделал:

Я пошел в репозиторий Ubuntu-x-swat: http://www.ubuntuupdates.org/ppa/ubuntu-x-swat?dist=oneiric

Выполните инструкции, которые они там предоставляют:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

sudo apt-get update

sudo apt-get install <package name>

И тогда вместо «заголовка пакета» xf86-input-mtrack (я действительно пытался, но я все еще получил ошибку «не удалось найти»), установил пакет xserver-xorg-input-mtrack

Итак, как я уже говорил, это была проблема между источниками и именами пакетов. Я знаю, что работает драйвер mtrack (что опять заставляет тачпад выходить из настроек мыши …)

Сначала попробуйте выполнить поиск с помощью apt-cache, чтобы найти точное совпадение в интересующем вас пакете.

 apt-cache search xserver-xorg-input 

Если нужный пакет отсутствует в списке, он недоступен в репозиториях, настроенных вашей системой. В моей системе доступны инструменты для ноутбуков и xserver-xorg-input-multitouch, но не xserver-xorg-input-mtrack.

Поиск google для 'ubuntu mtrack' приводит к http://www.ubuntuupdates.org/package/xorg-edgers/natty/main/base/xserver-xorg-input-mtrack

На этой странице показано, что пакет (по крайней мере, для ubuntu 11.04) находится не в основном репозитории, а доступен через PPA xorg-edgers http://www.ubuntuupdates.org/ppa/xorg-edgers?dist=natty

Следуйте инструкциям для включения PPA, обратите внимание, что имя пакета xf86-input-mtrack

 sudo add-apt-repository ppa:xorg-edgers/ppa sudo apt-get update sudo apt-get install xf86-input-mtrack 

Я думаю, что вы ищете драйвер жестов на нескольких сенсорных площадках для 11.04, 11.10 и 12.04

Пакеты расположены здесь http://www.ubuntuupdates.org/pm/xserver-xorg-input-mtrack

# ############### UNOFFICIAL REPOS # Сторонние двоичные репозитории Xorg Edgers – https://launchpad.net/~xorg-edgers

## Запустите эту команду: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 8844C542

добавьте это в свой источник.list

 deb http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu oneiric main 

# 3rd Party Source Repos Xorg Edgers (Источник) – https://launchpad.net/~xorg-edgers

## Запустите эту команду: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 8844C542

добавьте это в свой источник.list

 deb-src http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu oneiric main 

Управление репозиториями с помощью командной строки https://help.ubuntu.com/community/Repositories/CommandLine

ответил OP Благодаря BlueXrider, JasonD и CS мне удалось установить пакеты, которые я хотел. По-видимому, это была проблема с именами источников и пакетов. Это то, что я сделал:

Я пошел в репозиторий Ubuntu-x-swat: http://www.ubuntuupdates.org/ppa/ubuntu-x-swat?dist=oneiric

Выполните инструкции, которые они там предоставляют:

 sudo add-apt-repository ppa:ubuntu-x-swat/x-updates sudo apt-get update sudo apt-get install <package name> 

И тогда вместо «заголовка пакета» xf86-input-mtrack (я действительно пытался, но я все еще получил ошибку «не удалось найти»), установил пакет xserver-xorg-input-mtrack

Итак, как я уже говорил, это была проблема между источниками и именами пакетов. Я знаю, что работает драйвер mtrack (что опять заставляет тачпад выходить из настроек мыши …)