apt-get застрял в «Fetched XXKb в XXsec»

Я попытался установить кроссовер и после загрузки .deb со своего веб-сайта, я выполнил шаги, указанные при открытии его в Ubuntu Software Center:

В 64-битных вариантах Debian и некоторых вариантов Ubuntu сначала откройте терминал и запустите sudo dpkg --add-architecture i386 ; sudo apt-get update sudo dpkg --add-architecture i386 ; sudo apt-get update

Поскольку у меня Ubuntu 16.04 LTS 64 бит, я выполняю команду.

Но при копировании и вставке этой команды в мой терминал она остановилась на Fetched 535kb за 7 секунд и остановилась там около 20 минут. Я закончил его закрытие и попытался выполнить обе команды отдельно, но после выполнения команды sudo apt-get update он снова заглох после «Fetched XXKb в XXsec».

Я перезапустил свой компьютер и решил запустить программу обновления программного обеспечения, и она остается на уровне примерно 75% в течение нескольких часов.

Это известная ошибка и исправлена. Из комментария в отладчике ошибок установка следующих пакетов вручную решает проблему, по крайней мере для меня (URL-адреса для amd64, настройка URL-адресов для других архитектур):

 cd /tmp && mkdir asfix cd asfix wget https://launchpad.net/ubuntu/+archive/primary/+files/appstream_0.9.4-1ubuntu1_amd64.deb wget https://launchpad.net/ubuntu/+archive/primary/+files/libappstream3_0.9.4-1ubuntu1_amd64.deb sudo dpkg -i *.deb cd .. rm -r asfix 

Исправлена ​​ошибка. Пакеты можно загрузить и установить, открыв терминал (нажмите Ctrl + Alt + T ) и выполните следующие три команды:

 wget http://launchpadlibrarian.net/259142419/libappstream3_0.9.4-1ubuntu1_amd64.deb http://launchpadlibrarian.net/259142413/gir1.2-appstream_0.9.4-1ubuntu1_amd64.deb http://launchpadlibrarian.net/259142412/appstream-index_0.9.4-1ubuntu1_all.deb http://launchpadlibrarian.net/259142418/appstream_0.9.4-1ubuntu1_amd64.deb sudo dpkg -i libappstream3_0.9.4-1ubuntu1_amd64.deb gir1.2-appstream_0.9.4-1ubuntu1_amd64.deb appstream-index_0.9.4-1ubuntu1_all.deb appstream_0.9.4-1ubuntu1_amd64.deb sudo apt update 

Я столкнулся с подобной проблемой (застрял apt update 16.04, 2x apistreamcli на 100%), однако это не было связано с какой-либо конкретной установкой.

Для меня было достаточно, чтобы kill -sigterm застрял apistreamcli -процессы. После этого apt update && apt upgrade без проблем.