Проблема с драйвером ATI, fglrxinfo, возвращающая нулевую ошибку отображения, файл Xorg.conf выглядит фанки

У меня есть HP dv6, в частности, с ati radeon hd 5650. Это одна из тех замечательных гибридных видеокарт.

Я потратил много времени, пытаясь правильно установить драйверы для этой видеокарты. Моя основная причина для этого – запустить gnome 3, который не будет работать должным образом, когда я установлю драйвер fglrx из раздела дополнительных драйверов системных настроек. Я знаю, что желание запустить gnome 3 может показаться тривиальным, но я поставил перед собой задачу заставить это работать. Есть ли способ просто игнорировать графику ati и использовать графику Intel при использовании gnome?

Итак, переустановив ubuntu с помощью wubi, я сразу же последовал этому руководству.

Однако я столкнулся с некоторыми блоками. Когда я запустил команду aticonfig, я получил ответ

PowerXpress error: Cannot stat '/usr/lib64/fglrx': No such file or directory 

Я устанавливаю символическую связь между / usr / lib и / usr / lib64. Я не знаю, правильно ли это, но он получил мой вперед. Когда я перезагрузил компьютер после вызова aticonfig, я оказался висящим во время загрузки на черном экране. Это было как

 Checking Blah [ok] ..... Checking Battery State [ok] 

Были некоторые неудачи, но те, которые я видел, не были важны. Поэтому я перехожу в tty1 и пытаюсь запустить команду fglrxinfo, но я получаю ответ:

 Error: unable to open display (null) 

Итак, я смотрю на свой файл Xorg.conf, и содержимое, которое кажется странным, выглядит следующим образом:

 Section "ServerLayout" Identifier "aticonfig Layout" Screen 0 "aticonfig-Screen[0]-0" 0 0 EndSection Section "Module" EndSection Section "Monitor" Identifier "aticonfig-Monitor[0]-0" Option "VendorName" "Ati Proprietary Driver" Option "ModelName" "Generic Autodetecting Monitor" Option "DPMS" "true" EndSection Section "device" Identifier "aticonfig-Device[0]-0" Driver "fglrx" BusID "PCI:1:0:0" EndSection Section "Screen" Identifier "aticonfig-Screen[0]-0" Device "aticonfig-Device[0]-0" Monitor "aticonfig-Monitor[0]-0" DefaultDepth 24 Subsection "Display" Viewport 0 0 Depth 24 EndSubsection Section 

Я попытался сделать aticonfig --acpi-services=off а также состояние других потоков, но это не сработало.

Я бы очень признателен за любую помощь, которую я могу получить.

Благодарю.

РЕДАКТИРОВАТЬ

Я узнал, что если я удалю свой файл xorg.conf , я могу по крайней мере загрузить и войти в guuuuu gui

Вот как я работал над своей гибридной установкой Intel / AMD:

  • Обновите X.org до последней версии, добавив следующий PPA:

     sudo apt-add-repository ppa:xorg-edgers/ppa sudo apt-get update && sudo apt-get dist-upgrade 
  • Symbollically Link lib и lib64, чтобы избежать ошибки lib64:

     sudo ln -s /usr/lib/ /usr/lib64/ 
  • Установите драйвер ATI вручную НЕ создавайте пакеты deb:

     sudo sh ./amd-driver-installer-12-1-x86.x86_64.run 
  • Обновить X.org:

     sudo aticonfig --initial --nobackup 
  • После этого перезагрузите компьютер.

Я был связан с той же проблемой, в Ubuntu Precise x64 (Linux Mint Maya на самом деле). Пустой экран, ничего больше. Я должен был ввести пароль для входа, и после загрузки системы нажатие клавиши Alt-F1 открыло, по крайней мере, новый сеанс терминала. Поскольку интернет-соединение не работало (это KDE, он использует кошелек для хранения паролей, хотя теоретически можно ввести слепо его пароль, как при входе пользователя), вместо установки последнего xorg (как и Octavian) y просто сделал символическую ссылку:

 sudo ln -s /usr/lib32/ /usr/lib/ 

И перезагрузитесь. И это сработало.

Для ubuntu 14.4.2 – я только что скопировал cp -r /usr/lib64/fglrx /usr/lib/ . Поскольку aticonfig будет проверять разрешения для папки fglrx, а ln -s всегда rwxrwxrwx Я знаю, что это не хороший вариант, но все работает)