Какая версия Debian – это разные версии Ubuntu на основе?

У меня есть некоторые программные пакеты, настроенные для Ubuntu 10.04, 10.10 и 12.10, но теперь я должен установить их на Debian Squeeze. Я не смог Google для сопоставления между конкретными версиями Ubuntu и Debian. Может ли кто-то здесь помочь?

В частности, я хочу знать, какая версия Ubuntu соответствует Debian Squeeze.

Вы можете найти версию Debian, на которой ваша версия Ubuntu находится в файле: /etc/debian_version

С 10.04 до 17.04:

 17.10 artful stretch / sid 17.04 zesty stretch / sid 16.10 yakkety stretch / sid 16.04 xenial stretch / sid 15.10 wily jessie / sid 15.04 vivid jessie / sid 14.10 utopic jessie / sid 14.04 trusty jessie / sid 13.10 saucy wheezy / sid 13.04 raring wheezy / sid 12.10 quantal wheezy / sid 12.04 precise wheezy / sid 11.10 oneiric wheezy / sid 11.04 natty squeeze / sid 10.10 maverick squeeze / sid 10.04 lucid squeeze / sid 

sid – это дистрибутив разработки Debian (sid – testing – stable)

Вы можете узнать содержимое файла без установки всей системы, просмотрев исходные basefiles для basefiles пакета на Launchpad .

К сожалению, нет прямого сопоставления / etc / debian_version, как упоминалось в ответе Джейкоба, дает приблизительную идею, но она действительно отражает только один пакет, и указанный пакет – это пакет, который локально модифицирован в Ubuntu, поэтому он не будет автоматически выведен из Debian.

В частности, Ubuntu часто опережает Debian в базовых пакетах, таких как libc6. Попытка установить пакет, основанный на Ubuntu на современной версии Debian, скорее всего, приведет к ошибкам версии на libc6.

Согласно https://superuser.com/questions/407745/wrong-libc6-version-in-debian-squeeze-can-i-go-back Сжатие Debian имело libc6 2.11. Согласно http://web.archive.org/web/20110705212424/http://packages.ubuntu.com/search?keywords=libc6 ubuntu 10.04 lucid также имел libc6 2.11. Таким образом, пакеты для 10.4 ясных – это ИМО, наиболее вероятно работающие на Squeeze.

В зависимости от того, какие другие библиотеки нужны вашей программе, вы вполне можете найти, что нужна конкретная сборка для сжатия Debian.