«E: Не удалось найти обновление пакета», когда я пытаюсь обновить свою систему, почему?

У меня почти час попытки обновить мою установку, вот как я пытаюсь это сделать:

$ sudo apt-get install update [sudo] password for braiam: Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package update 

Это просто не работает! Не install update текста, который я должен поставить после sudo apt-get чтобы установить обновления в мою систему Ubuntu? Если нет, какую команду мне писать?

Этот вопрос пытается решить некоторые распространенные ошибки пользователей, не используемых для системы APT и apt-get .

Инструмент APT apt-get имеет простые команды, которые вам нужно знать перед тем, что они делают, и в каких обстоятельствах его использовать.

Если вы хотите обновить список пакетов , то правильная команда:

 sudo apt-get update 

только то! Вам не нужно ничего писать до и после. Это просто sudo + apt-get + update . Готово.

Чтобы установить пакеты или программы в вашей системе, вам сначала нужно знать имя пакета . Если вы не знаете, что для имени пакета рекомендуется использовать графический интерфейс (например, Ubuntu Software Center или packagekit), выполните поиск и установите свою программу с его помощью. Если вы знаете имя пакета, вам нужно только:

 sudo apt-get install package_name 

Замените package_name своего пакета. Вы можете установить сразу несколько пакетов, просто напишите их пробелом между ними. Если вы все еще получаете:

E: Не удалось найти пакет имя_пакета

Затем попробуйте обновить список или просмотреть инструкции, за которыми вы следуете, возможно, это просто типографская ошибка. Если имя этого пакета неизвестно для apt-get, это ошибка, которую вы получите.

Для обновления пакетов, которые вы уже установили, aka обновите всю свою систему, вам нужно сделать следующее:

 sudo apt-get upgrade 

Ничего больше. Он обновит все пакеты, которые вы установили в своей системе.