gedit-developer-плагины на Ubuntu 13.10 Saucy Salamander

Я установил gedit-developer-плагины на новый Ubuntu 13.10 Saucy Salamander

Я приветствовал gedit (из терминала), но когда я включаю плагин GDP (в данном случае GDP Find), я получаю следующую ошибку:

(gedit: 3640): libpeas-WARNING **: Не удалось найти загрузчик 'python' для плагина 'gdpfind'

Такая же ошибка отображается только при включении плагинов ВВП, остальные работают хорошо.

Любое решение для повторного запуска этих плагинов?

Я боюсь, что все зависит от разработчика, ответственного за плагин. Но сначала вы можете попробовать решение, представленное здесь: Проблема с плагинами Gedit и Python3 от 13.04 .

Я обновился до Lubuntu 13.10 и установил версию gedit, доступную в программном центре (v 3.8.3). Затем я попытался установить doublelesave и markdown -preview, оба из которых работали для меня в Lubuntu 13.04. Я столкнулся с той же проблемой, что и вы, и сменой Loader= как предлагалось в первой ссылке, мне не помогло.

Я сделал интернет-поиск и пришел к выводу, что проблема может быть чем-то, что отдельный разработчик плагина должен изменить, если для вас не работает Loader= fix.

Это означает, что старый плагин (0.5.15) использует питон, предоставленный старым gedit (3.6)

можно получить стабильные плагины (1.1.0), которые с gedit (3.8.3) в saucy на https://launchpad.net/~sinzui/+archive/ppa

Просто беги:

 sudo add-apt-repository ppa:sinzui/ppa sudo apt-get update sudo apt-get install gedit-developer-plugins 

И тогда вы можете включить плагины ВВП.

EDIT для UBUNTU 14.04

Чтобы включить плагин формата ВВП, вы должны установить python-pocket-lint , просто запустите:

 sudo apt-get install python-pocket-lint 

Если вы спешите, просто делайте все в одной команде:

 sudo add-apt-repository -y ppa:sinzui/ppa && sudo apt-get update && sudo apt-get -y install gedit-developer-plugins python-pocket-lint