Установите более новую версию git на LTS

Я не могу обновить lucid lynx 10.04 LTS, потому что новые дистрибутивы ubuntu не работают на этом компьютере. Мне нужно установить git версии 1.7.10 для управления учетными данными. Версия Git – 1.7.0.4 на 10.04 LTS:

$ dpkg -l *git* +++-==============-==============-============================================ ii git-core 1:1.7.0.4-1ubu fast, scalable, distributed revision control 

Есть ли способ или backport для установки git 1.7.10 или новее?

PPA ppa:git-core/ppa обеспечивает backports самой стабильной версии Git для различных версий Ubuntu.

В командной строке вы можете добавить PPA, используя:

 sudo add-apt-repository ppa:git-core/ppa 

Если вы получили сообщение об ошибке, указывающее, что add-apt-repository не найден, установите его с помощью:

 sudo apt-get install python-software-properties