Как установить версию gitg 2.7 под 15.04?

Я обновился до Ubuntu 15.04. Отгруженная версия gitg – 3.15.1 – в Ubuntu 14.10 это было 2.7.3.

Мне очень нравится устанавливать старую версию снова, так как новая версия очень неудобна для обработки. Как снова установить старую версию. Он не указан в версии package force version .

Я удалил новую версию. Я загрузил .deb-пакет из http://packages.ubuntu.com/utopic/amd64/gitg/download , но когда я пытаюсь установить его с помощью двойного щелчка, устанавливается новая версия и появляется сообщение об ошибке:

 Package operation failed The installation or removal of a software package failed. Selecting previously unselected package gitg. (Reading database ... (Reading database ... 5% (Reading database ... 10% (Reading database ... 15% (Reading database ... 20% (Reading database ... 25% (Reading database ... 30% (Reading database ... 35% (Reading database ... 40% (Reading database ... 45% (Reading database ... 50% (Reading database ... 55% (Reading database ... 60% (Reading database ... 65% (Reading database ... 70% (Reading database ... 75% (Reading database ... 80% (Reading database ... 85% (Reading database ... 90% (Reading database ... 95% (Reading database ... 100% (Reading database ... 241499 files and directories currently installed.) Preparing to unpack .../gitg_0.2.7-3_amd64.deb ... Unpacking gitg (0.2.7-3) ... dpkg: dependency problems prevent configuration of gitg: libgit2-glib-1.0-0:amd64 (0.22.0-0ubuntu1) breaks gitg (<< 3.15.1) and is installed. Version of gitg to be configured is 0.2.7-3. dpkg: error processing package gitg (--install): dependency problems - leaving unconfigured Processing triggers for gnome-menus (3.10.1-0ubuntu5) ... Processing triggers for desktop-file-utils (0.22-1ubuntu3) ... Processing triggers for bamfdaemon (0.5.1+15.04.20150202-0ubuntu1) ... Rebuilding /usr/share/applications/bamf-2.index... Processing triggers for mime-support (3.58ubuntu1) ... Processing triggers for hicolor-icon-theme (0.14-0ubuntu1) ... Processing triggers for libglib2.0-0:i386 (2.44.0-1ubuntu3) ... Processing triggers for libglib2.0-0:amd64 (2.44.0-1ubuntu3) ... Processing triggers for man-db (2.7.0.2-5) ... Errors were encountered while processing: gitg 

Когда я нажимаю на repair после этого, устанавливается версия 3.15.1 . Если я не нажимаю на ремонт, то устанавливается 2.7.3 (и выполняется).

Итак, есть ли лучший способ установить старую версию gitg?

Откройте терминал и запустите следующие команды:

 sudo dpkg -i gitg_0.2.7-3_amd64.deb sudo apt-get remove libgit2-glib-1.0-0 

и приостановлено:

 sudo apt-mark hold gitg 

Все меняется на противоположное

 sudo apt-mark unhold gitg sudo apt-get upgrade 

Этот пакет можно получить на странице https://packages.debian.org/jessie/amd64/gitg/download . (Если вы используете другую архитектуру, чем amd64 , выберите ее здесь .)