Intereting Posts
Заметки Tomboy, записанные zeitgeist, не отображаются в тире Unity. Почему нет? Sudo также является паролем для входа в систему – почему? как изменить? Как запустить хром как root Есть ли функционирующий wifi-инструмент (а не сетевой менеджер), который работает на открытом Wi-Fi и поддерживает VPN? IP Messenger не работает в Ubuntu 14.04 LTS Как я могу получить более традиционное раскрывающееся меню для Unity? Не удается возобновить после приостановки и выключения питания с помощью ubuntu 14.04 Как создать загрузочный USB-накопитель OS X Mountain Lion на Ubuntu? Как переопределить ограничение скорости повторной передачи ограничено? Индикатор блокировки клавиатуры для панели Xfce Преимущества использования прокси Squid на сервере Ubuntu Как загрузить драйвер synaptics на 12.04? (Прокрутка не работает) Как просмотреть, в каких группах находится пользователь? Ссылка apt не работает в браузере Opera Приложение, которое будет копировать mp3 с аналоговой кассеты?

install.packages () Rstudio сервер AWS ubuntu error

У меня есть экземпляр AWS, работающий с ubuntu 12.04 и shiny сервер, а также Rstudio, однако, когда я пытаюсь добавить пакеты, я получаю сообщение об ошибке при попытке загрузить библиотеку ()

для следующей команды: install.packages("jsonlite", dependencies = TRUE, repos="http://cran.cs.wwu.edu") вывод терминала показывает, что загрузка происходит без каких-либо проблем со следующим в качестве последней строки The downloaded source packages are in '/tmp/RtmpO02nLU/downloaded_packages'

Очевидно, что библиотека () показывает ошибку, например // Error in library(jsonlite) : there is no package called 'jsonlite' Что-то не так с этим процессом? как я могу установить пакеты для работы с моей Instance / environment?

EDIT :: Я понимаю, что есть возможность создать файл подкачки, задаваясь вопросом с экземпляром t1, есть ли что-то действительно неэффективное с настройкой? вместо того, чтобы делать это или просто обновлять экземпляр, бросая в него больше памяти.

Вы можете использовать sudo R для запуска R. Иначе это не позволит вам установить R-пакет в каталог библиотеки R. Как только вы выполните sudo R, снова используйте install.packages. Надеюсь, это сработает для вас. Раньше у меня была аналогичная проблема.

У меня была такая же проблема с использованием виртуальной машины через бродягу.

После обновления версии R я получил полезное предупреждение о том, что установка пакета R shiny неудачей из-за нехватки памяти. Я использовал 512 Мб для ОЗУ, этого недостаточно. После настройки Vagrantfile :

 config.vm.provider "virtualbox" do |vb| # Customize the amount of memory on the VM: b.memory = "2048" end 

Это сработало. Следует отметить, что для установки dplyr мне пришлось увеличить виртуальную память до 2048 Мб.

Надеюсь это поможет