JAVA заблокирован из-за уровня безопасности на Ubuntu 13.10

JAVA блокируется из-за уровня безопасности. Однако я могу изменить уровни безопасности в Ubuntu.

Я приурочен к последней JAVA:

sudo add-apt-repository ppa:webupd8team/java sudo apt-get update sudo apt-get install oracle-java8-installer pst007x@pst007x-Serval-Professional:~$ java -version java version "1.7.0_45" Java(TM) SE Runtime Environment (build 1.7.0_45-b18) Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode) 

Я получаю сообщение об ошибке:

JAVA (TM) БЫЛО ЗАБЛОКИРОВАНО, ПОТОМУ ЧТО ЭТО НЕ ВЫЙТИ: ПРОЙДИТЕ В ЭТОМ ВРЕМЕНИ? / ОБНОВИТЬ?

Я выбираю:

Запустить это время

Затем появляется всплывающее окно:

Ваша версия Java устарела.

Нажмите «Обновить», чтобы установить рекомендуемую последнюю версию. Нажмите «Блокировать», чтобы остановить контент Java в своем браузере или позже, чтобы продолжить, и напомнить позже.

Я выбираю LATER, затем он терпит неудачу, говоря:

Настройки безопасности заблокировали запуск приложения с устаревшей или истекшей версией JAVA

…. Но я использую последнюю версию Linux …

Неужели Ubuntu перестала поддерживать JAVA сейчас?

Помоги пожалуйста! 🙂

Сайт JAVA:

Проверенная галочка завершения версии Java. Поздравляем!

У вас установлен рекомендованный Java (1.8.0-ea).

Это сайт, который не работает: JPL

Я просто пошел на сайт, который вы показали, и у меня не было проблем. Я использую opendjdk7 и плагин веб-браузера icedtea через программный центр, и я не использую java, предоставленный oracle. Вам нужна фактическая java? Если нет, вы можете удалить его и использовать openjdk или просто openjre, если вам не нужны материалы для разработки.

Что касается Ubuntu и java, Oracle изменил лицензирование, и java не может быть предоставлен. Это не бесплатное программное обеспечение. Вы можете прочитать лицензию, чтобы понять ее лучше. Таким образом, Ubuntu не может предоставить его через свои собственные источники (поэтому вам нужно было настроить ppa для его получения).

Что касается ошибок, которые вы получаете, они могут поступать от взаимодействия с вашим браузером. Я знаю, что у нас есть программное обеспечение на работе, которое сумасшедшее с java-версиями.

Если вам не нужна настоящая java, дайте openjre / jdk попробовать и плагин icedtea.

Я нахожу, что эти «они работают на моей машине» и «используют то, что я использую», досаждают. Если вы используете Oracle JDK и имеете эту проблему в Linux, добавьте следующую строку в файл ~/.java/deployment/deployment.properties :

 deployment.security.level=MEDIUM 

Затем перезапустите браузер. Это эквивалент Linux, связанный со всеми стандартами Windows и Mac OS X: «установите уровень безопасности на« Средний », загрязняя результаты поиска« как это сделать в Linux ».

Удачи!