Как установить jdk1.2 рядом с jdk1.8

Я новичок в Linux и ubuntu … Я пытаюсь запустить программу, старую (2001), в MakeFile говорится, что javac – это jdk1.2 (или 1.3), но я уже не сказал javac 9-internal .

Могу ли я установить javac jdk1.2 рядом с этой java, чтобы сделать программу? В общем, каково решение для запуска таких старых проектов?

да, это довольно просто, просто загрузите jdk, извлеките его где-нибудь и установите путь в свой .bashrc-файл, как показано ниже

 # User specific aliases and functions JAVA_HOME=/mnt/install/jdk1.8.0_77 JRE_HOME=/mnt/install/jdk1.8.0_77/bin export PATH=$JAVA_HOME/bin:$JRE_HOME:$MAVEN/bin:$PATH 

затем снова закрыть и открыть терминал или сделать это

 source ~/.bashrc