Intereting Posts
Как установить libdb4.8 ++ – dev или эквивалент на 13.10? Steam требует BETA «Экспериментальные» драйверы. Это безопасно? Сжать или удалить swap с 4 ГБ оперативной памяти и SSD? hp-probe найти сеть принтеров или альтернативную Возможность монтировать, но не в состоянии просматривать содержимое зашифрованных ЛУКС-накопителей Как получить доступ к порту на удаленном сервере с помощью SSH? Шифровать SSD или нет? Не удается установить привязку после ее удаления. Какие PHP-редакторы, основанные на PHP и Xdebug, используют людей, отличные от Eclipse, Netbeans (все на основе Java) или VIM Выделение с помощью grep не работает в Xterm Добавьте переменную окружения android-studio / bin / to PATH Обновлены обновления. Удалось установить на рабочий стол, но не может установить драйверы Fglrx назад Как выровнять текст Conky в центре рабочего стола? Как установить Windows после установки Ubuntu? Два шлюза в одной сети

Отсутствует /lib/libc.so.6

Программное обеспечение, которое я устанавливаю, требует /lib/libc.so.6 , но его нет на месте:

 $> ls -l /lib/libc* lrwxrwxrwx 1 root root 14 2011-10-09 06:02 /lib/libcap.so.2 -> libcap.so.2.20 -rw-r--r-- 1 root root 18832 2011-02-16 03:42 /lib/libcap.so.2.20 -rw-r--r-- 1 root root 1620736 2012-05-23 07:19 /lib/libcrypto.so.0.9.8 

libc и libc6-dev . Запуск apt-get upgrade glibc не решает этого.

Что делать, чтобы разрешить эту зависимость?

Быстрое решение.

Откройте терминал ( Ctrl + Alt + T ) и выполните следующие команды:

Для 64-битного Ubuntu:

 sudo ln -s /lib64/x86_64-linux-gnu/libc.so.6 /lib64/libc.so.6 

Для 32-разрядного Ubuntu:

 sudo ln -s /lib/i386-linux-gnu/libc.so.6 /lib/libc.so.6 

На моем 64-битном Ubuntu это должно было быть:

 sudo ln -s /lib/x86_64-linux-gnu/libc.so.6 /lib/libc.so.6 

(то есть 64-битная библиотека ниже / lib, not / lib64)