Intereting Posts
Не удается ответить «hello»> x.txt даже с sudo? Определить местоположение назначения apt-get install <package>? Имеет ли смысл делать резервную копию всего раздела в отличие от своих файлов? Что случилось с tzdata-java в Xenial 16.04? Кто-нибудь знает, как использовать WRAP-текст в ячейке в Libreoffice Calc? Соединяются ли телефоны Android с Ubuntu? Что квалифицирует приложение как часто используемое? Подключение к Bluetooth-устройству из командной строки Отключить эффект белого конца документа для прокрутки в Gedit 3.18.3 Ищете небольшое исправление для Ambiance themed Nautilus window! Можно ли активировать две сети на одном физическом соединении в сетевом менеджере? Как использовать некоторые аргументы предыдущей команды без повторного набора Shellshock: Как я могу обновить только Bash без перезагрузки? Как просмотреть файлы с помощью Gloobus-Preview? Как использовать мой домашний каталог в отдельном разделе?

Невозможно заблокировать libgtk2.0-dev на ubuntu 12.04

Я использую opencv 3 на ubunut 12.04, и при отображении изображения сообщение об ошибке просит меня создать библиотеку с libgtk2.0-dev. Я попробовал sudo apt-get install libgtk2.0-dev, но я получил следующую ошибку.

teraflops@teraflops-Inspiron-3542:~$ sudo apt-get install libgtk2.0-devReading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libgtk2.0-dev : Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed E: Unable to correct problems, you have held broken packages. teraflops@teraflops-Inspiron-3542:~$ 

Я почти пробовал все онлайн-решения, как здесь, 1 и здесь 2 без каких-либо результатов. Пожалуйста, предложите мне какие-либо средства для решения проблемы. Я попытался установить libpango1-dev и libcairo2-dev отдельно, но оба имеют поврежденные зависимости, приводящие к libfontconfig1-dev . Попытка установить позже дает

 teraflops@teraflops-Inspiron-3542:~$ sudo apt-get install libfontconfig1-dev Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libfontconfig1-dev : Depends: libfontconfig1 (= 2.8.0-3ubuntu9.1) but 2.10.1-0ubuntu3 is to be installed E: Unable to correct problems, you have held broken packages. 

Любое предложение / решение приветствуется

Довольно простая проблема –

libfontconfig1-dev : Depends: libfontconfig1 (= 2.8.0-3ubuntu9.1) but 2.10.1-0ubuntu3 is to be installed

У вас есть libfontconfig1 2.10.1-0ubuntu3 с 12.10, но они находятся на 12.04. Таким образом, вам нужно будет заменить этот пакет версией 12.04 и любыми другими 12,10 пакетами (-ами), которые вы установили, что может вызвать конфликты. Так что удачи там …

apt-cache policy libfontconfig1 или apt-cache madison libfontconfig1 должна четко показать это

Попробуйте установить все из них одновременно, например:

 sudo apt-get install libgtk2.0-dev libpango1-dev libcairo2-dev libfontconfig1-dev 

Иногда зависимости пакета связаны с пакетами из архитектуры x86_64. Выполните следующие шаги:

  1. sudo dpkg --add-architecture i386
  2. sudo apt-get update
  3. sudo apt-get install libgtk2.0-dev

Я надеюсь вам помочь.

Unable to correct problems, you have held broken packages.

Эта строка с полученного вами результата (при попытке установить libgtk2.0-dev), похоже, указывает на необходимость исправления сломанных и отсутствующих пакетов.

Попробуй это:

 sudo apt-get update && sudo apt-get upgrade --fix-missing --fix-broken 

Затем, считая, что это было успешно, вы можете без проблем запускать команду install для libgtk2.0-dev

 sudo apt-get install libgtk2.0-dev 

Если он все еще не работает, попробуйте найти, какие пакеты сдерживаются:

 dpkg --get-selections | grep hold 

Если эта команда дает вам какой-либо вывод (должны быть имена пакетов любых пакетов), попробуйте это:

 sudo apt-get install <packagename> 

Затем попробуйте установить libgtk2.0-dev снова.

Если он все еще не работает, возможно, подумайте о том, чтобы выполнить dist-upgrade

 sudo apt-get dist-upgrade 

Надеюсь, это поможет!

Проверьте это:

Загрузите эти файлы в 32 бита:

 http://mirrors.kernel.org/ubuntu/pool/main/g/gtk+2.0/libgtk2.0-dev_2.24.10-0ubuntu6_i386.deb http://mirrors.kernel.org/ubuntu/pool/main/g/gtk+2.0/gir1.2-gtk-2.0_2.24.10-0ubuntu6_i386.deb http://mirrors.kernel.org/ubuntu/pool/main/a/atk1.0/libatk1.0-dev_2.4.0-0ubuntu1_i386.deb http://mirrors.kernel.org/ubuntu/pool/main/c/cairo/libcairo2-dev_1.10.2-6.1ubuntu2_i386.deb http://mirrors.kernel.org/ubuntu/pool/main/g/gdk-pixbuf/libgdk-pixbuf2.0-dev_2.26.1-1_i386.deb http://mirrors.kernel.org/ubuntu/pool/main/g/glib2.0/libglib2.0-dev_2.32.1-0ubuntu2_i386.deb http://mirrors.kernel.org/ubuntu/pool/main/g/gtk+2.0/libgtk2.0-0_2.24.10-0ubuntu6_i386.deb http://mirrors.kernel.org/ubuntu/pool/main/g/gtk+2.0/libgtk2.0-common_2.24.10-0ubuntu6_all.deb http://mirrors.kernel.org/ubuntu/pool/main/p/pango1.0/libpango1.0-dev_1.30.0-0ubuntu2_i386.deb http://mirrors.kernel.org/ubuntu/pool/main/libx/libxcomposite/libxcomposite-dev_0.4.3-2build1_i386.deb http://mirrors.kernel.org/ubuntu/pool/main/libx/libxdamage/libxdamage-dev_1.1.3-2build1_i386.deb http://mirrors.kernel.org/ubuntu/pool/main/p/pkg-config/pkg-config_0.26-1ubuntu1_i386.deb 

Или загрузите эти файлы на 64 бит:

 http://mirrors.kernel.org/ubuntu/pool/main/g/gtk+2.0/libgtk2.0-dev_2.24.10-0ubuntu6_amd64.deb http://mirrors.kernel.org/ubuntu/pool/main/g/gtk+2.0/gir1.2-gtk-2.0_2.24.10-0ubuntu6_amd64.deb http://mirrors.kernel.org/ubuntu/pool/main/a/atk1.0/libatk1.0-dev_2.4.0-0ubuntu1_amd64.deb http://mirrors.kernel.org/ubuntu/pool/main/c/cairo/libcairo2-dev_1.10.2-6.1ubuntu2_amd64.deb http://mirrors.kernel.org/ubuntu/pool/main/g/gdk-pixbuf/libgdk-pixbuf2.0-dev_2.26.1-1_amd64.deb http://mirrors.kernel.org/ubuntu/pool/main/g/glib2.0/libglib2.0-dev_2.32.1-0ubuntu2_amd64.deb http://mirrors.kernel.org/ubuntu/pool/main/g/gtk+2.0/libgtk2.0-0_2.24.10-0ubuntu6_amd64.deb http://mirrors.kernel.org/ubuntu/pool/main/g/gtk+2.0/libgtk2.0-common_2.24.10-0ubuntu6_all.deb http://mirrors.kernel.org/ubuntu/pool/main/p/pango1.0/libpango1.0-dev_1.30.0-0ubuntu2_amd64.deb http://mirrors.kernel.org/ubuntu/pool/main/libx/libxcomposite/libxcomposite-dev_0.4.3-2build1_amd64.deb http://mirrors.kernel.org/ubuntu/pool/main/libx/libxdamage/libxdamage-dev_1.1.3-2build1_amd64.deb http://mirrors.kernel.org/ubuntu/pool/main/p/pkg-config/pkg-config_0.26-1ubuntu1_amd64.deb 

Установите их с помощью команды:

 sudo dpkg --force-all -i *.deb 

Выполнено в каталоге загрузки

У меня была та же проблема, которая пыталась установить Wireshark 1.7.0 на моем Ubuntu 12.04 – libgtk2.0-dev требует libgtk2.0-dev .

Все застряло из-за пакета libfontconfig1-dev :

  1. Добавьте точный обновляющий deb-сервер в ваш /etc/apt/sources.list . Для Франции:
 deb http://fr.archive.ubuntu.com/ubuntu/ precise-updates main restricted 
  1. Обновить aptitude :
 apt-get update 
  1. Теперь вы можете установить сломанный пакет
 apt-get install libfontconfig1-dev 
  1. Поместите все проблемные пакеты в одну и ту же командную строку. Вот:
 apt-get install libgtk2.0-dev libpango1.0-dev libcairo2-dev