Intereting Posts
Как создать пользовательский репозиторий на Ubuntu 14.04 Почему Wired Internet не работает в Ubuntu 16.04 LTS? Найдите удаленный пакет aptitude, который предоставляет команду Как создать домашнюю папку пользователя после создания учетной записи? Предотвратите Alt, выделив строку меню Информация о драйвере, как Windows 7? Не удается удалить старые ядра Команда, чтобы определить, работает ли Ubuntu на виртуальной машине? BCM43602 – bluetooth не работает – видит MAC устройства, но не будет будет ubuntu автоматически управлять скоростью вентилятора на основе тепла, как окна Как остановить Alt от запуска глобального меню? Почему Ubuntu поддерживает только версии в течение ограниченного времени (и что это значит)? Добавить второй процессор в Virtualbox, виртуализованный 32-разрядный Ubuntu Что такое Namoroka, и должен ли я использовать его вместо Minefield или Firefox 4? Как вы переключаете звук из динамиков на USB-динамик из командной строки?

make: dh: Команда не найдена

Когда я пытаюсь запустить файл .run на nautilus, указатель превращается в колесо и ничего не делает, я изменил разрешение сделать его исполняемым, также сначала он только попытался открыть его с помощью gedit, поэтому мне пришлось вручную выбрать выполнение это как программа из меню. После того, как я запустил его на терминале и попытаюсь построить пакет для последующей установки, он дает мне эту ошибку, и я не могу понять, в чем проблема.

chmod 744 debian/pxpress/switch* dh build make: dh: Command not found make: *** [build-arch] Error 127 dpkg-buildpackage: error: debian/rules build gave error exit status 2 Cleaning in directory . dpkg-checkbuilddeps: Unmet build dependencies: debhelper (>= 7) dh-modaliases execstack debuild: fatal error at line 1328: You do not appear to have all build dependencies properly met. You can use mk-build-deps to generate a dummy package which Depends on all the required packages, or you can install them manually using dpkg or apt using the error messages just above this message. 

На IRC кто-то сказал мне, что это могут быть devscripts, но после установки он по-прежнему дал мне ошибку, поэтому я удалил ее снова. Я пытаюсь установить это, потому что тот, который находится в ubuntu fglrx-updates, не позволит мне открыть amdccl в качестве администратора, открывается небольшое черное окно с запросом пароля, но после этого ничего не будет сделано, и он слишком быстро закрывается, чтобы увидеть какое-либо сообщение , Есть идеи?

Кстати, я также использовал эту команду sudo sh *.run --buildpkg Ubuntu/trusty но я думаю, что получил ту же ошибку. Данг, я проверил сайт ati http://support.amd.com/en-us/kb-articles/Pages/amdcatalyst13-12linreleasenotes.aspx, похоже, что драйвер несовместим с 14.04 или ядром 3.13, но я просто пытаясь построить пакет, не устанавливая его, он должен хотя бы сделать это правильно? Я все еще хотел бы исправить эту проблему.

    Парень в IRC был почти там, но не совсем. Пакет, который вам нужен, называется dh-make no devscripts . Простое решение sudo apt-get install dh-make должно устранить проблему.

    Как знать:

     chmod 744 debian/pxpress/switch* dh build make: dh: Command not found make: *** [build-arch] Error 127 dpkg-buildpackage: error: debian/rules build gave error exit status 2 

    dh build начинает создание пакета debian с помощью скриптов debhelper, все эти скрипты добавляются с dh_ строки dh_ . В этом случае dh называется помощником dh_make для создания пакета debian.

    У вас есть еще одна подсказка:

     dpkg-checkbuilddeps: Unmet build dependencies: debhelper (>= 7) dh-modaliases execstack 

    Для создания пакета вам нужны debhelper, dh-modaliases и execstack. debhelper предлагает dh-make, и предложения обычно устанавливаются.

    введите описание изображения здесь

    Установите свой драйвер, хотя программный центр.

    Программный центр Ubuntu> Меню Правка> Источники программного обеспечения> Дополнительные драйверы

    ИЛИ

    выполните эти команды в своем терминале:

    sudo apt-get install build-essential linux-headers-generic
    sudo apt-get install fglrx

    Затем вы сможете использовать Catalyst Control Center.