Как установить .NET framework v4.0.30319 на вино?

Я хотел установить osu !, но это не работает, когда вы идете на PlayOnLinux (сообщение об ошибке и ничего не происходит).

Затем я последовал за этим видео на Youtube .

Как показало видео (в 2:44), я нажал кнопку « Запустить файл .exe» на этом виртуальном диске, после чего я нажал на osu!install.exe а затем я получу это сообщение:

Для запуска этого приложения сначала необходимо установить одну из следующих версий .NET Framework: v4.0.30319

Можете ли вы рассказать мне, как установить это?

С winetricks и 32-битным префиксом WINE. Помните, что PlayOnLinux использует отдельный префикс вина для каждого установленного приложения. По этой причине вы должны использовать WINEPREFIX :

 sudo apt-get install winetricks WINEARCH=win32 WINEPREFIX=~/.wine32 winetricks dotnet40 

Но, как вы можете прочитать здесь , сценарий установки для osu

 Script is outdated and no longer works. 

И в курсе, osu нуждается в dotnet20 а не dotnet40 .

Попробуйте следовать официальной документации по установке Osu! на winetricks hq