Невозможность установки opencv 2.4.9 на ubuntu 14.04

Я пытаюсь установить opencv 2.4.9 на ubuntu 14.04. Я получаю сообщение об ошибке при компиляции файлов. Когда я запускаю:

cmake -D CMAKE_BUILD_TYPE=RELEASE -D CMAKE_INSTALL_PREFIX=/usr/local -D WITH_TBB=ON -D BUILD_NEW_PYTHON_SUPPORT=ON -D WITH_V4L=ON -D WITH_QT=ON -D WITH_OPENGL=ON .. 

я получил

 runtime library [libz.so] in /usr/lib may be hidden by files in: /usr/local/lib 

И если я попытаюсь продолжить работу

 sudo make -j2 

Прогресс не превышает 13%, и следующая ошибка печатается

 somepath/OpenCV/opencv-2.4.10/modules/core/src/system.cpp:280:10: error: inconsistent operand constraints in an 'asm' 

Я попытался обновить gcc-компилятор, как и многие темы, но ничего не помогло.

Я надеюсь найти какую-то помощь отсюда