Pthreads в XAMPP в Linux

Что касается библиотеки pthreads, PHP должен быть скомпилирован с ZTS.Is это возможно установить Pthreads в XAMPP в linux.Because для Windows XAMPP, это может быть не проблема.

Не могли бы вы исправить мой сценарий для этих установок или ссылок с XAMPP? Спасибо

По умолчанию PHP поставляется с поддержкой командной строки PECL (PHP Extension Community Library), что избавляет нас от необходимости компилировать расширение вручную. Вместо этого мы можем запустить команду установки ниже.

$ pecl install pthreads $ echo "extension=pthreads.so" >> /etc/php.ini 

Теперь, когда расширение уже успешно установлено, мы должны теперь включить расширение, которое будет загружено в конфигурационный файл «php.ini». Мы можем проверить, что расширение было успешно загружено с помощью интерпретатора PHP, запустив и проверив вывод из следующей команды.

 $ php -m | grep pthreads 

Более подробную информацию вы получите по ссылке ниже

Компиляция PHP 5.5 с поддержкой ZTS и pthreads

в последних системах ОС Linux pthread уже доступен.

для проверки использования yolinux.com