Intereting Posts
Что такое способ командной строки для поиска больших файлов / каталогов для удаления и освобождения пространства? Найти установленный словарь Как я могу запускать Sublime Text из пусковой установки как root каждый раз? Отформатировать раздел, размер блока для фотографий Проблема Backporting SQLite 3.8.1 в Ubuntu Точность от Trusty Как добраться до идеальной конфигурации Jackd, которая работает безотказно и из коробки? Троянская версия файла «egrep», обнаруженная OSSEC HIDS Как отключить приветственное сообщение, когда ssh на сервере? Невозможно переключиться на TTY / виртуальную консоль на Mac Book Pro, 14.04 Как заставить веб-камеру работать с skype на Ubuntu 13.04? Что такое механизм блокировки экрана в KDE? Ubuntu 16.04 – Unity не загружается – не появляется Launcher или Dash Как перенести настройку LAMP на новый сервер Ubuntu? mysqld не установлен на ubuntu 16.04 Не удалось подключиться к Windows VPN в Ubuntu 11.10

Steam требует libgl1-mesa-dri: i386, libgl1-mesa-glx: i386

Я только что установил Steam на свой Ubuntu 13.10 64 бит, и он работает хорошо, и я могу играть в игры, но каждый раз, когда я его запускаю, я получаю следующее приглашение:

Steam needs to install these additional packages: libgl1-mesa-dri:i386, libgl1-mesa-glx:i386 [sudo] password for user: ............................................................................................................................................ Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libgl1-mesa-dri:i386 : Depends: libdrm-intel1:i386 (>= 2.4.38) but it is not going to be installed Depends: libdrm-nouveau2:i386 (>= 2.4.38) but it is not going to be installed Depends: libdrm-radeon1:i386 (>= 2.4.31) but it is not going to be installed Depends: libdrm2:i386 (>= 2.4.38) but it is not going to be installed Depends: libglapi-mesa:i386 but it is not going to be installed libgl1-mesa-glx:i386 : Depends: libdrm2:i386 (>= 2.3.1) but it is not going to be installed Depends: libglapi-mesa:i386 (= 9.2.1-1ubuntu3) but it is not going to be installed Depends: libx11-6:i386 (>= 2:1.4.99.1) but it is not going to be installed Depends: libxcb-dri2-0:i386 (>= 1.8) but it is not going to be installed Depends: libxcb-glx0:i386 (>= 1.8) but it is not going to be installed Depends: libxcb1:i386 but it is not going to be installed Depends: libxdamage1:i386 (>= 1:1.1) but it is not going to be installed Depends: libxext6:i386 but it is not going to be installed Depends: libxfixes3:i386 but it is not going to be installed Depends: libxxf86vm1:i386 but it is not going to be installed E: Unable to correct problems, you have held broken packages. Press return to continue: 

Я сделал следующее:

 sudo dpkg --add-architecture i386 sudo apt-get update 

Но никаких изменений не произошло.

 $ apt-cache policy libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libgl1-mesa-dri:i386: Installed: (none) Candidate: 9.2.1-1ubuntu3 Version table: 9.2.1-1ubuntu3 0 500 http://archive.ubuntu.com/ubuntu/ saucy/main i386 Packages libgl1-mesa-glx:i386: Installed: (none) Candidate: 9.2.1-1ubuntu3 Version table: 9.2.1-1ubuntu3 0 500 http://archive.ubuntu.com/ubuntu/ saucy/main i386 Packages $ sudo apt-get check Reading package lists... Done Building dependency tree Reading state information... Done 

после sudo apt-get install aptitude && sudo aptitude install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386

 The following NEW packages will be installed: libdrm-intel1:i386{ab} libdrm-nouveau2:i386{ab} libdrm-radeon1:i386{ab} libdrm2:i386{ab} libelf1:i386{a} libexpat1:i386{a} libffi6:i386{a} libgl1-mesa-dri:i386{b} libgl1-mesa-glx:i386{b} libglapi-mesa:i386{ab} libllvm3.3:i386{a} libpciaccess0:i386{a} libtxc-dxtn-s2tc0:i386{a} libx11-6:i386{a} libx11-xcb1:i386{a} libxau6:i386{a} libxcb-dri2-0:i386{ab} libxcb-glx0:i386{ab} libxcb1:i386{ab} libxdamage1:i386{a} libxdmcp6:i386{a} libxext6:i386{a} libxfixes3:i386{a} libxxf86vm1:i386{a} zlib1g:i386{a} 0 packages upgraded, 25 newly installed, 0 to remove and 0 not upgraded. Need to get 13,8 MB of archives. After unpacking 45,0 MB will be used. The following packages have unmet dependencies: libxcb-dri2-0 : Breaks: libxcb-dri2-0:i386 (!= 1.10-1~xedgers~saucy1) but 1.9.1-3ubuntu1 is to be installed. libxcb-dri2-0:i386 : Breaks: libxcb-dri2-0 (!= 1.9.1-3ubuntu1) but 1.10-1~xedgers~saucy1 is installed. libdrm-intel1 : Breaks: libdrm-intel1:i386 (!= 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy) but 2.4.46-1ubuntu1 is to be installed. libdrm-intel1:i386 : Breaks: libdrm-intel1 (!= 2.4.46-1ubuntu1) but 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy is installed. libgl1-mesa-dri : Breaks: libgl1-mesa-dri:i386 (!= 10.1.0~git20140102.5a51c1b0-0ubuntu0ricotz~saucy) but 9.2.1-1ubuntu3 is to be installed. libgl1-mesa-dri:i386 : Breaks: libgl1-mesa-dri (!= 9.2.1-1ubuntu3) but 10.1.0~git20140102.5a51c1b0-0ubuntu0ricotz~saucy is installed. libdrm-radeon1 : Breaks: libdrm-radeon1:i386 (!= 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy) but 2.4.46-1ubuntu1 is to be installed. libdrm-radeon1:i386 : Breaks: libdrm-radeon1 (!= 2.4.46-1ubuntu1) but 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy is installed. libxcb1 : Breaks: libxcb1:i386 (!= 1.10-1~xedgers~saucy1) but 1.9.1-3ubuntu1 is to be installed. libxcb1:i386 : Breaks: libxcb1 (!= 1.9.1-3ubuntu1) but 1.10-1~xedgers~saucy1 is installed. libglapi-mesa : Breaks: libglapi-mesa:i386 (!= 10.1.0~git20140102.5a51c1b0-0ubuntu0ricotz~saucy) but 9.2.1-1ubuntu3 is to be installed. libglapi-mesa:i386 : Breaks: libglapi-mesa (!= 9.2.1-1ubuntu3) but 10.1.0~git20140102.5a51c1b0-0ubuntu0ricotz~saucy is installed. libxcb-glx0 : Breaks: libxcb-glx0:i386 (!= 1.10-1~xedgers~saucy1) but 1.9.1-3ubuntu1 is to be installed. libxcb-glx0:i386 : Breaks: libxcb-glx0 (!= 1.9.1-3ubuntu1) but 1.10-1~xedgers~saucy1 is installed. libgl1-mesa-glx : Breaks: libgl1-mesa-glx:i386 (!= 10.1.0~git20140102.5a51c1b0-0ubuntu0ricotz~saucy) but 9.2.1-1ubuntu3 is to be installed. libgl1-mesa-glx:i386 : Breaks: libgl1-mesa-glx (!= 9.2.1-1ubuntu3) but 10.1.0~git20140102.5a51c1b0-0ubuntu0ricotz~saucy is installed. libdrm-nouveau2 : Breaks: libdrm-nouveau2:i386 (!= 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy) but 2.4.46-1ubuntu1 is to be installed. libdrm-nouveau2:i386 : Breaks: libdrm-nouveau2 (!= 2.4.46-1ubuntu1) but 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy is installed. libdrm2 : Breaks: libdrm2:i386 (!= 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy) but 2.4.46-1ubuntu1 is to be installed. libdrm2:i386 : Breaks: libdrm2 (!= 2.4.46-1ubuntu1) but 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy is installed. The following actions will resolve these dependencies: Remove the following packages: 1) gir1.2-totem-1.0 2) gnome-contacts 3) gnome-control-center 4) gnome-control-center-datetime 5) gnome-control-center-signon 6) gnome-control-center-unity 7) gstreamer1.0-clutter 8) gstreamer1.0-plugins-bad 9) indicator-bluetooth 10) libcheese-gtk23 11) libcheese7 12) libclutter-1.0-0 13) libclutter-gst-2.0-0 14) libclutter-gtk-1.0-0 15) libcogl-pango12 16) libcogl12 17) libegl1-mesa 18) libegl1-mesa-drivers 19) libgbm1 20) libgl1-mesa-dri 21) libgstreamer-plugins-bad1.0-0 22) libtotem0 23) libxatracker1 24) ubuntu-desktop 25) xorg 26) xserver-xorg-glamoregl 27) xserver-xorg-video-all 28) xserver-xorg-video-vmware Keep the following packages at their current version: 29) libdrm-intel1:i386 [Not Installed] 30) libdrm-nouveau2:i386 [Not Installed] 31) libdrm-radeon1:i386 [Not Installed] 32) libdrm2:i386 [Not Installed] 33) libgl1-mesa-dri:i386 [Not Installed] 34) libgl1-mesa-glx:i386 [Not Installed] 35) libglapi-mesa:i386 [Not Installed] 36) libx11-6:i386 [Not Installed] 37) libxcb-dri2-0:i386 [Not Installed] 38) libxcb-glx0:i386 [Not Installed] 39) libxcb1:i386 [Not Installed] 40) libxdamage1:i386 [Not Installed] 41) libxext6:i386 [Not Installed] 42) libxfixes3:i386 [Not Installed] 43) libxxf86vm1:i386 [Not Installed] Leave the following dependencies unresolved: 44) gnome-bluetooth recommends gnome-control-center 45) indicator-power recommends gnome-control-center (>= 3.1) | ubuntu-system-settings 46) indicator-sound recommends gnome-control-center | ubuntu-system-settings 47) libaccount-plugin-1.0-0 recommends gnome-control-center-signon 48) unity recommends gnome-control-center-unity 49) unity recommends indicator-bluetooth 50) xserver-xorg recommends libgl1-mesa-dri 51) ubuntu-restricted-addons recommends gstreamer1.0-plugins-bad 52) gnome-control-center-data recommends gnome-control-center (>= 1:3.6.3-0ubuntu45.2) 53) indicator-datetime recommends gnome-control-center-datetime | ubuntu-system-settings 54) xserver-xorg-core recommends libgl1-mesa-dri (>= 7.10.2-4) 55) libgl1-mesa-glx recommends libgl1-mesa-dri (>= 7.2) 56) xserver-xorg-video-nouveau recommends libgl1-mesa-dri (>= 7.11.1) 57) libegl1-mesa recommends libegl1-mesa-drivers Accept this solution? [Y/n/q/?] 

Это мои дополнительные PPA:

 ./danielrichter2007-grub-customizer-saucy.list ./danielrichter2007-grub-customizer-saucy.list.save ./dropbox.list ./dropbox.list.save ./google-chrome.list ./google-chrome.list.save ./linrunner-tlp-saucy.list ./linrunner-tlp-saucy.list.save ./me-davidsansome-clementine-saucy.list ./me-davidsansome-clementine-saucy.list.save ./steam.list ./steam.list.save ./webupd8team-java-saucy.list ./webupd8team-java-saucy.list.save 

Мой ответ больше подходит для этой проблемы, которая отмечена как дублируемая для этой публикации. Я установил пустой новый 14.04.2 64-битный, а затем попытался установить клиент Steam (неважно, с сайта steampowered или apt-get install steam). В результате он застрял с

 Steam may not run:libGL.so.1 Steam needs to install these additional packages: libgl1-mesa-dri:i386, libgl1-mesa-glx:i386 [sudo] password for numb: .............................. Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.4) unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed Depends: libcheese7 (>= 3.0.1) but it is not going to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. 

Ну, я пробовал много чего. Но то, что помогло (благодаря этому ответу ), было простым – просто установить нужные libs с немного другим именем:

 sudo apt-get install libgl1-mesa-glx-lts-utopic:i386 

Ваша проблема в том, что вы используете PPA. Пакеты PPA обычно не являются многоархивальными, и вам нужно многоархиво. Чтобы решить эту проблему, вы должны удалить PPA:

 sudo rename 's/\.list$/.list.disable/' /etc/apt/sources.list.d/*.list sudo apt-get update sudo aptitude -f install libgl1-mesa-dri:i386=9.2.1-1ubuntu3 libgl1-mesa-glx:i386=9.2.1-1ubuntu3 

Это решит проблему.

@Braiam был прав в своем ответе, но мне нужно было правильно понизить пакеты с помощью ppa-purge

 $ sudo ppa-purge xorg-edgers 

В качестве альтернативы вы можете использовать

 apt-cache madison <packagename> 

для получения списка доступных версий, затем установите определенную предыдущую версию как

 sudo apt-get install <packagename>=<version> 

Эта финналия работала для меня:

для графики NVIDIA:

 apt-get install libgl1-nvidia-glx-i386 

для ATI / AMD:

 apt-get install libgl1-fglrx-glx-i386