Как установить svn?

Я пытаюсь установить svn и запутаться в проблемах. Команда, которую я запускаю, – sudo apt-get install svn . Когда я запускаю это, я получаю сообщение об ошибке «Не удалось найти пакет svn». Почему это? Как это исправить?

Пакет называется подрывной Установить подрывную деятельность (сокращенно svn ). Вы должны установить его, выполнив:

 sudo apt-get install subversion 

Этот пакет также содержит демон svnserve (не запущен по умолчанию). Если вы хотите разместить сервер subversion через HTTP, вы должны установить apache2 и настроить его соответствующим образом.

Нет пакета с именем SVN. Вы можете набрать эту команду на терминале.

 sudo apt-get install subversion 

Затем вы можете проверить его с помощью команды svn

 svn co "type here your checkout URL without double quotes" svn status svn commit ...........your file name 

apt-get – замечательный менеджер пакетов, но часто имена пакетов точно не называются так, как вы ожидали. (Очевидно, не ошибка apt-get), например, загрузка java не apt-get install java . что касается вашей проблемы, имя пакета svn в apt-get является подрывной.

apt-get install subversion

получайте удовольствие от ваших потребностей в подрывной деятельности!