Intereting Posts
Msgstr "Загрузка тома занимает всего 0 байт на диске" Как я могу преобразовать .m2ts в .mkv? Есть ли способ модулировать мой голос на лету? Есть ли где-нибудь инструкции, объясняющие, как устранять проблемы со звуком на настольных компьютерах Ubuntu? Получите 2 или более индикатора раскладки клавиатуры в XFCE Установка Trac с Subversion Темная тема GTK для Ubuntu 16.04 (Unity) Как сделать приложение java совместимым с глобальным меню единства? Как я могу удалить индикаторы приложения по умолчанию, например, индикатор мощности или уровня громкости в Unity? Будет ли свободное пространство 20 ГБ бесплатно после истечения 6-месячной действующей музыкальной дорожки? Можно ли конвертировать 7z в tar напрямую? Что такое «./configure; делать; make install "do? Как установить расширение ClamAV для PHP 5? Ubuntu 13.04 не будет подключаться к общему сетевому диску Как сделать панель инструментов приложения только иконкой?

Библиотеки разработки Ubuntu 14.04 Qt5?

Я хочу создавать приложения, требующие Qt5 через CMake.

Какие библиотеки мне нужно установить для этого?

То, что я пробовал до сих пор, ищет все, что содержит qt 5 core и dev, но оказалось пустым:

apt-cache search qt | grep dev | grep core 

возвращает только

 libtulip-dev - Tulip graph library - core development files 

Единственное, что кажется на полпути, – «libqt5core5a», но установка, которая не предоставляет никаких библиотек разработки …

Нужны ли мне дополнительные репозитории? Возможно, из Кубунту?

Поиск в Интернете еще не дал мне правильных ответов (возможно, не правильные ключевые слова, я знаю, но: o). Я, например, нашел этот вопрос: какой пакет мне нужен для создания приложения Qt 5 и CMake? , но нет никакого пакета qtcore5-dev в надежных репозиториях, кажется …

Изменить: при дальнейших экспериментах у меня был установлен qmake, но версия 4.8.6 (qt4-qmake). Попытка установить версию 5.x не принесла никакой радости, однако – ( sudo apt-get purge qt4-qmake && sudo apt-get install qt5-qmake ) – qmake теперь сообщает:

 qmake: could not exec '/usr/lib/x86_64-linux-gnu/qt4/bin/qmake': No such file or directory 

Здесь что-то сломано в репозиториях?