Затвор не устанавливается в Ubuntu 16.04 из-за неудовлетворенных зависимостей

Я попытался установить Shutter в Ubuntu 16.04 после этих трех команд

  1. sudo add-apt-repository ppa: shutter / ppa
  2. Обновление sudo apt-get
  3. sudo apt-get install shutter

После выполнения шага 2, т.е. sudo apt-get update, мой вывод следующий:

Ign:1 http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.2 InRelease Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease Hit:3 http://dl.google.com/linux/chrome/deb stable Release Ign:4 http://archive.canonical.com/ubuntu precise InRelease Ign:5 http://extras.ubuntu.com/ubuntu precise InRelease Hit:7 http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.2 Release Hit:9 https://deb.nodesource.com/node_6.x xenial InRelease Hit:10 http://ppa.launchpad.net/git-core/ppa/ubuntu xenial InRelease Hit:11 http://archive.canonical.com/ubuntu precise Release Hit:12 http://extras.ubuntu.com/ubuntu precise Release Ign:13 http://us.archive.ubuntu.com/ubuntu precise InRelease Hit:16 http://ppa.launchpad.net/rvm/smplayer/ubuntu xenial InRelease Hit:17 http://us.archive.ubuntu.com/ubuntu precise-security InRelease Hit:18 http://ppa.launchpad.net/shutter/ppa/ubuntu xenial InRelease Get:19 http://us.archive.ubuntu.com/ubuntu precise-updates InRelease [55.7 kB] Hit:20 http://ppa.launchpad.net/ubuntuhandbook1/apps/ubuntu xenial InRelease Hit:21 http://ppa.launchpad.net/videolan/master-daily/ubuntu xenial InRelease Hit:22 http://ppa.launchpad.net/videolan/stable-daily/ubuntu xenial InRelease Hit:23 http://us.archive.ubuntu.com/ubuntu precise-backports InRelease Hit:24 http://ppa.launchpad.net/webupd8team/atom/ubuntu xenial InRelease Hit:25 http://ppa.launchpad.net/webupd8team/brackets/ubuntu xenial InRelease Hit:26 http://us.archive.ubuntu.com/ubuntu precise Release Hit:28 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease Hit:29 http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu xenial InRelease Fetched 55.7 kB in 3s (14.5 kB/s) Reading package lists... Done W: http://archive.canonical.com/ubuntu/dists/precise/Release.gpg: Signature by key 630239CC130E1A7FD81A27B140976EAF437D05B5 uses weak digest algorithm (SHA1) W: http://extras.ubuntu.com/ubuntu/dists/precise/Release.gpg: Signature by key C47415DFF48C09645B78609416126D3A3E5C1192 uses weak digest algorithm (SHA1) W: http://us.archive.ubuntu.com/ubuntu/dists/precise-security/InRelease: Signature by key 630239CC130E1A7FD81A27B140976EAF437D05B5 uses weak digest algorithm (SHA1) W: http://us.archive.ubuntu.com/ubuntu/dists/precise-updates/InRelease: Signature by key 630239CC130E1A7FD81A27B140976EAF437D05B5 uses weak digest algorithm (SHA1) W: http://us.archive.ubuntu.com/ubuntu/dists/precise-backports/InRelease: Signature by key 630239CC130E1A7FD81A27B140976EAF437D05B5 uses weak digest algorithm (SHA1) W: http://us.archive.ubuntu.com/ubuntu/dists/precise/Release.gpg: Signature by key 630239CC130E1A7FD81A27B140976EAF437D05B5 uses weak digest algorithm (SHA1) 

Вывод с шага 3, т.е. sudo apt-get install shutter Я получаю

  Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: shutter : Depends: gnome-web-photo but it is not going to be installed Depends: libgnome2-perl but it is not going to be installed Depends: libgnome2-vfs-perl but it is not going to be installed Depends: libgnome2-wnck-perl but it is not going to be installed Depends: libgoo-canvas-perl but it is not going to be installed Depends: libgtk2-appindicator-perl but it is not installable Depends: libgtk2-imageview-perl but it is not going to be installed Depends: libgtk2-trayicon-perl but it is not going to be installed Depends: libgtk2-unique-perl but it is not going to be installed Depends: libnet-oauth-perl but it is not going to be installed Depends: libproc-processtable-perl but it is not going to be installed Depends: libjson-xs-perl but it is not going to be installed E: Unable to correct problems, you have held broken packages. 

Чтобы решить проблему E: Unable to correct problems, you have held broken packages. Я попробовал это

  • E: Не удалось устранить проблемы, у вас были сломанные пакеты .
  • Не удалось устранить проблемы, у вас есть сломанные пакеты

Пока нет успеха. Любая помощь приветствуется.

PS После проверки моего /etc/apt/sources.list я нашел каждую ссылку так, чтобы в ней упоминалось precise в ней.

 ############################################################# ################### OFFICIAL UBUNTU REPOS ################### ############################################################# ###### Ubuntu Main Repos # deb http://us.archive.ubuntu.com/ubuntu/ precise main restricted universe mul$ # deb-src http://us.archive.ubuntu.com/ubuntu/ precise main restricted universe$ ###### Ubuntu Update Repos deb http://us.archive.ubuntu.com/ubuntu/ precise-security main restricted unive$ deb http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted univer$ deb http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted univ$ deb-src http://us.archive.ubuntu.com/ubuntu/ precise-security main restricted u$ deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted un$ deb-src http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted $ ###### Ubuntu Partner Repo deb http://archive.canonical.com/ubuntu precise partner deb-src http://archive.canonical.com/ubuntu precise partner 

Благодаря подсказкам от @George, я смог наконец установить затвор . Я отключил все репозитории в списке с точным указанием . Удивительно, что в каждом репозитории упоминается об этом, заменил его следующим списком

 ###### Ubuntu Main Repos deb http://us.archive.ubuntu.com/ubuntu/ xenial main restricted universe multiverse deb-src http://us.archive.ubuntu.com/ubuntu/ xenial main restricted universe multiverse ###### Ubuntu Update Repos deb http://us.archive.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse deb http://us.archive.ubuntu.com/ubuntu/ xenial-updates main restricted universe multiverse deb http://us.archive.ubuntu.com/ubuntu/ xenial-proposed main restricted universe multiverse deb http://us.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates main restricted universe multiverse deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-proposed main restricted universe multiverse deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse 

Затем снова попробуйте sudo apt-get update а затем sudo apt-get install shutter чтобы успешно установить его.