Поддерживает ли Ubuntu Bluetooth 3.0?

Я запускаю 11.10 на моем Thinkpad E420, и у него встроен Bluetooth 3.0, но когда я использую свой Plantronics Backbeat 903+ (который использует Bluetooth 2.1), я получаю ужасно непоследовательный звук со многими полными отсевами.

У меня также есть USB-ключ Bluetooth 2.1 Bluetooth, и когда я присоединяюсь к нему и использую его вместо внутреннего адаптера, я получаю идеальное качество звука. Вот почему мне интересно узнать, поддерживает ли Ubuntu поддержку Bluetooth 3.0. Есть предположения?

AFAIK Ubuntu поддерживает Bluetooth 3, и даже если это не так, ваш адаптер Bluetooth 3 поддерживает Bluetooth 2.1 для устройств Bluetooth 2.1. Скорее всего, это просто проблема с драйвером, или ваш внутренний адаптер может просто плохо работать с этим устройством из-за того, как он построен (например, если он не использует достаточную мощность для передачи или что-то еще. Возможно, не получая достаточно ясного приема).

Не на 100%, но я также заметил чрезвычайно короткие возможности подключения и отсева с этой гарнитурой Plantronics Backbeat при использовании ее с телефоном Android 2.3 … если это проблема с драйвером Linux, это может быть не характерно для Ubuntu (или даже традиционного Linux) … но в равной степени это может быть проблема совместимости оборудования между этими чипами bluetooth. Вы смогли проверить, присутствует ли эта проблема в Windows? … это может помочь определить, есть ли проблема в программном или аппаратном обеспечении.