Драйвер Ubuntu Haswell HD4600 не загружается

У меня есть lenovo y410p. Экран начинается с пробела, который я исправил установкой nomodeset в настройках загрузки. Но если я проверю журналы xorg, драйвер или карта Intel не распознаются, а система работает как Gaallium 3D (LLVM).

Вставка моего /var/log/Xorg.0.log

[ 4.000] X.Org X Server 1.13.4 Release Date: 2013-04-17 [ 4.000] X Protocol Version 11, Revision 0 [ 4.000] Build Operating System: Linux 2.6.24-32-xen x86_64 Ubuntu [ 4.000] Current Operating System: Linux vipul-Lenovo-IdeaPad-Y410P 3.10.1-031001-generic #201307131550 SMP Sat Jul 13 19:51:31 UTC 2013 x86_64 [ 4.000] Kernel command line: BOOT_IMAGE=/vmlinuz-3.10.1-031001-generic root=UUID=aea2b405-1ccd-4da8-b7dd-2190e5843e7b ro nomodeset quiet splash pcie_aspm=force i915.lvds_downclock=1 drm.vblankoffdelay=1 i915.semaphores=1 vt.handoff=7 [ 4.000] Build Date: 08 May 2013 02:34:03PM [ 4.000] xorg-server 2:1.13.4~git20130508+server-1.13-branch.10c42f57-0ubuntu0ricotz~raring (For technical support please see http://www.ubuntu.com/support) [ 4.000] Current version of pixman: 0.28.2 [ 4.000] Before reporting problems, check http://wiki.x.org to make sure that you have the latest version. [ 4.000] Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown. [ 4.001] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Jul 14 10:32:52 2013 [ 4.002] (==) Using config file: "/etc/X11/xorg.conf" [ 4.002] (==) Using system config directory "/usr/share/X11/xorg.conf.d" [ 4.003] (==) No Layout section. Using the first Screen section. [ 4.003] (==) No screen section available. Using defaults. [ 4.003] (**) |-->Screen "Default Screen Section" (0) [ 4.003] (**) | |-->Monitor "<default monitor>" [ 4.003] (==) No device specified for screen "Default Screen Section". Using the first device section listed. [ 4.003] (**) | |-->Device "HD Graphics 4600, Haswell Mobile (GT3)" [ 4.003] (==) No monitor specified for screen "Default Screen Section". Using a default monitor configuration. [ 4.003] (==) Automatically adding devices [ 4.003] (==) Automatically enabling devices [ 4.003] (==) Automatically adding GPU devices [ 4.006] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist. [ 4.006] Entry deleted from font path. [ 4.006] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist. [ 4.006] Entry deleted from font path. [ 4.006] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist. [ 4.006] Entry deleted from font path. [ 4.006] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist. [ 4.006] Entry deleted from font path. [ 4.006] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist. [ 4.006] Entry deleted from font path. [ 4.006] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist. [ 4.006] Entry deleted from font path. [ 4.006] (==) FontPath set to: /usr/share/fonts/X11/misc, /usr/share/fonts/X11/Type1, built-ins [ 4.006] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules" [ 4.006] (II) The server relies on udev to provide the list of input devices. If no devices become available, reconfigure udev or disable AutoAddDevices. [ 4.006] (II) Loader magic: 0x7f7051380d20 [ 4.006] (II) Module ABI versions: [ 4.006] X.Org ANSI C Emulation: 0.4 [ 4.006] X.Org Video Driver: 13.1 [ 4.006] X.Org XInput driver : 18.0 [ 4.006] X.Org Server Extension : 7.0 [ 4.007] (--) PCI:*(0:0:2:0) 8086:0416:17aa:3801 rev 6, Mem @ 0xc2000000/4194304, 0xb0000000/268435456, I/O @ 0x00005000/64 [ 4.007] (--) PCI: (0:1:0:0) 10de:0fe4:17aa:3801 rev 161, Mem @ 0xc0000000/16777216, 0x90000000/268435456, 0xa0000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/524288 [ 4.007] (II) Open ACPI successful (/var/run/acpid.socket) [ 4.008] Initializing built-in extension Generic Event Extension [ 4.008] Initializing built-in extension SHAPE [ 4.008] Initializing built-in extension MIT-SHM [ 4.008] Initializing built-in extension XInputExtension [ 4.008] Initializing built-in extension XTEST [ 4.008] Initializing built-in extension BIG-REQUESTS [ 4.008] Initializing built-in extension SYNC [ 4.008] Initializing built-in extension XKEYBOARD [ 4.008] Initializing built-in extension XC-MISC [ 4.008] Initializing built-in extension SECURITY [ 4.008] Initializing built-in extension XINERAMA [ 4.008] Initializing built-in extension XFIXES [ 4.008] Initializing built-in extension RENDER [ 4.008] Initializing built-in extension RANDR [ 4.008] Initializing built-in extension COMPOSITE [ 4.008] Initializing built-in extension DAMAGE [ 4.008] Initializing built-in extension MIT-SCREEN-SAVER [ 4.008] Initializing built-in extension DOUBLE-BUFFER [ 4.008] Initializing built-in extension RECORD [ 4.008] Initializing built-in extension DPMS [ 4.008] Initializing built-in extension X-Resource [ 4.008] Initializing built-in extension XVideo [ 4.008] Initializing built-in extension XVideo-MotionCompensation [ 4.008] Initializing built-in extension SELinux [ 4.008] Initializing built-in extension XFree86-VidModeExtension [ 4.008] Initializing built-in extension XFree86-DGA [ 4.008] Initializing built-in extension XFree86-DRI [ 4.008] Initializing built-in extension DRI2 [ 4.008] (II) LoadModule: "glx" [ 4.010] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so [ 4.011] (II) Module glx: vendor="X.Org Foundation" [ 4.011] compiled for 1.13.4, module version = 1.0.0 [ 4.011] ABI class: X.Org Server Extension, version 7.0 [ 4.011] (==) AIGLX enabled [ 4.011] Loading extension GLX [ 4.011] (II) LoadModule: "intel" [ 4.011] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so [ 4.013] (II) Module intel: vendor="X.Org Foundation" [ 4.013] compiled for 1.13.4, module version = 2.21.11 [ 4.013] Module class: X.Org Video Driver [ 4.013] ABI class: X.Org Video Driver, version 13.1 [ 4.013] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale, Sandybridge Desktop (GT1), Sandybridge Desktop (GT2), Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1), Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+), Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2), Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server, Ivybridge Server (GT2), HD Graphics, HD Graphics 4600, Haswell Desktop (GT3), HD Graphics, HD Graphics 4600, Haswell Mobile (GT3), HD Graphics, HD Graphics P4600/P4700, Haswell Server (GT3), Haswell (GT1), Haswell (GT2), Haswell (GT3), HD Graphics, Haswell (GT2), Haswell (GT3), Haswell SDV Desktop (GT1), Haswell SDV Desktop (GT2), Haswell SDV Desktop (GT3), Haswell SDV Mobile (GT1), Haswell SDV Mobile (GT2), Haswell SDV Mobile (GT3), Haswell SDV Server (GT1), Haswell SDV Server (GT2), Haswell SDV Server (GT3), Haswell SDV (GT1), Haswell SDV (GT2), Haswell SDV (GT3), Haswell SDV (GT1), Haswell SDV (GT2), Haswell SDV (GT3), Haswell ULT Desktop (GT1), Haswell ULT Desktop (GT2), Iris(TM) Graphics 5100, HD Graphics, HD Graphics 4400, HD Graphics 5000, Haswell ULT Server (GT1), Haswell ULT Server (GT2), Iris(TM) Graphics 5100, Haswell ULT (GT1), Haswell ULT (GT2), Iris(TM) Graphics 5100, HD Graphics, HD Graphics 4200, Iris(TM) Graphics 5100, Haswell CRW Desktop (GT1), HD Graphics 4600, Iris(TM) Pro Graphics 5200, Haswell CRW Mobile (GT1), HD Graphics 4600, Iris(TM) Pro Graphics 5200, Haswell CRW Server (GT1), Haswell CRW Server (GT2), Iris(TM) Pro Graphics 5200, Haswell CRW (GT1), Haswell CRW (GT2), Iris(TM) Pro Graphics 5200, Haswell CRW (GT1), Haswell CRW (GT2), Iris(TM) Pro Graphics 5200, ValleyView PO board [ 4.014] (++) using VT number 7 [ 4.015] (EE) No devices detected. [ 4.015] (==) Matched intel as autoconfigured driver 0 [ 4.015] (==) Matched vesa as autoconfigured driver 1 [ 4.015] (==) Matched modesetting as autoconfigured driver 2 [ 4.015] (==) Matched fbdev as autoconfigured driver 3 [ 4.015] (==) Assigned the driver to the xf86ConfigLayout [ 4.015] (II) LoadModule: "intel" [ 4.015] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so [ 4.015] (II) Module intel: vendor="X.Org Foundation" [ 4.015] compiled for 1.13.4, module version = 2.21.11 [ 4.015] Module class: X.Org Video Driver [ 4.015] ABI class: X.Org Video Driver, version 13.1 [ 4.015] (II) UnloadModule: "intel" [ 4.015] (II) Unloading intel [ 4.015] (II) Failed to load module "intel" (already loaded, 32624) [ 4.015] (II) LoadModule: "vesa" [ 4.015] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so [ 4.015] (II) Module vesa: vendor="X.Org Foundation" [ 4.015] compiled for 1.12.99.902, module version = 2.3.2 

Хорошо, похоже, моя проблема заключалась в том, что яркость по умолчанию была самой низкой, что привело к простому экрану. Я попытался изменить яркость, и все, кажется, работает правильно.