Articles of зависимые

Ошибка незавершенных ошибок в вине

На днях я попытался что-то установить, но не могу вспомнить, что было в этот момент. Теперь я больше не могу устанавливать что-либо из-за ошибок, перечисленных на этих изображениях. Кто-то, пожалуйста, пожалуйста, помогите мне! Спасибо вам, любезно! Ошибка удаления вина ( dpkg -l | grep i386 , Выделил файл, который не позволяет мне устанавливать что-либо еще […]

где «apt-cache зависит» собирает информацию о зависимости от?

Я хочу изменить зависимости пакета debian, и я внесли изменения в его файл управления. Но список apt-cache depends pkg_name все еще отображает удаленные зависимости. Итак, где эта команда выводит список зависимостей debian-пакета? Не из файла управления?

libapt-inst1.4: i386 fais для установки

Сегодня я не знал об обновлениях, некоторые из них были libapt. Поэтому я нажимаю «Install Updates», и я получил эту ошибку: Следующие пакеты имеют неудовлетворенные зависимости: libapt-inst1.4:i386: Depends: libapt-pkg4.12 (>= 0.8.16~exp12ubuntu10.2) but 0.8.16~exp12ubuntu10.3 is installed Depends: libc6 (>= 2.4) but 2.15-0ubuntu10 is installed Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is installed Depends: libstdc++6 (>= 4.4.0) […]

Неудовлетворенные зависимости (linux-headers, linux-image)

Я пытаюсь установить программу на моем Linux. При запуске: sudo apt-get install nams я продолжаю получать: Чтение списков пакетов … Готово Создание дерева зависимостей Чтение информации о состоянии … Готово Возможно, вы захотите запустить «apt-get -f install», чтобы исправить это: Следующие пакеты имеют неудовлетворенные зависимости: linux-image-extra-4.4.0-71-generic: Зависит от linux-image-4.4.0-71-generic, но он не будет установлен linux-image-generic: […]

Проблема с неудовлетворенными зависимостями при попытке установки apt-get

Каждый раз, когда я пытаюсь установить пакеты python с помощью команды: sudo apt-get install python-package Я получаю следующий вывод: Reading package lists… Done Building dependency tree Reading state information… Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: linux-headers-generic : Depends: linux-headers-3.2.0-36-generic but it is not […]

«Неудовлетворительные зависимости» после обновления до Ubuntu 15.10

Я обновил ubuntu до 15.10, затем попытался скомпилировать приложение gtk и обнаружил, что у меня не было установлен GTK. Так что я побежал sudo apt-get install libgtk-3-dev но это результат Reading package lists… Done Building dependency tree Reading state information… Done Some packages could not be installed. This may mean that you have requested an […]

Как исправить сломанный libstdc ++ 6, который также ломается apt

Кажется, я что-то испортил с помощью ручного обновления gcc в прошлом, который не стал проблемой до сегодняшнего дня, когда я обновлялся с 14.04 по 16.04. А именно, система, похоже, считает, что версия libstdc++6 в порядке, в то время как apt (и многие другие программы) жалуются, что это не так (потому что общая библиотека на самом […]

openscad не удается установить: сломанная зависимость libqt5scintilla2-12v5

Попытка установить opensad из репозитория пакетов ubuntu на Kubuntu версии 16.04 LTS. При установке очень быстро происходит следующее сообщение: Reading package lists… Done Building dependency tree Reading state information… Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that […]

apt-get проблемы с установкой python-software-properties

Итак, я пытался добавить репозиторий с помощью add-apt-repository, и я получил эту ошибку: sudo add-apt-repository ppa:gijzelaar/opencv2 [sudo] password for foo: Traceback (most recent call last): File "/usr/bin/add-apt-repository", line 8, in <module> from softwareproperties.SoftwareProperties import SoftwareProperties ImportError: No module named softwareproperties.SoftwareProperties Как и n00b, я подумал, что было бы неплохо просто удалить и переустановить свойства python-software […]

Исчезающая зависимость: gir1.2-launchpad-integration-3.0

Я пытаюсь установить facebook-webapp, но зависимость gir1.2-launchpad-integration-3.0 не найдена и не указана как деинсталлируемая. Я не смог найти его где-нибудь, кроме ссылок на « Нитро » (который, по-видимому, не работает ни из-за отсутствия этого пакета). Кто-нибудь знает, что происходит и как я могу обойти это? Я запускаю Ubuntu 14.04, новый инсталлятор и начинающий пользователь.