Articles of склонный

E: неверная строка 54 в списке источников /etc/apt/sources.list (dist parse)

Возврат команды sudo apt-get update E: Malformed line 54 in source list /etc/apt/sources.list (dist parse) как выход. Пожалуйста, помогите мне решить эту проблему. Вот строки 53 и 54 в списке источников: deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse deb http://archive.canonical.com/lucid partner

узнать дату последнего обновления (составителем) подходящего пакета

Как видно из заголовка, мне интересно, можно ли узнать дату последнего обновления (сопровождающим) apt пакета. Таким образом, я могу понять, устарел ли пакет. Я пробовал как apt-cache show и packages.ubuntu.com , но, похоже, такой информации нет.

apt-get дает ошибку

Когда я пытаюсь запустить обновление, обновление или установку, я всегда получаю сообщение об ошибке: Setting up initscripts (2.88dsf-34) … Can't exec "insserv": No such file or directory at /usr/sbin/update-rc.d line 391. update-rc.d: error: insserv rejected the script header dpkg: error processing initscripts (–configure): subprocess installed post-installation script returned error exit status 255 configured to not […]

Последние доступные пакеты

Из-за ошибки доступности в последних версиях Ubuntu мне придется вернуться к Ubuntu 12.04 LTS, когда 12.10 выйдет на пенсию позже в этом месяце . Я вижу, что Ubuntu 12.04 поставляется с Firefox 11.0 , LibreOffice 3.5 и другим устаревшим (функциональным) программным обеспечением. Хотя у меня нет проблем с компиляцией Firefox, LibreOffice и других приложений, я […]

Легкий способ загрузки пакета из PPA?

Мне интересно, есть ли инструмент командной строки, который можно использовать для загрузки пакета из источника (стандартные источники Ubuntu или PPA)? Я знаю, что только что установленные пакеты найдены в / var / cache / apt / archives, и я, таким образом, могу проверить пакет оттуда. Однако, если я установил пакет давно, я не хочу его […]

Проблема с etc / apt / sources.list

Я новичок в ubuntu, и я создал несколько документов случайно, когда я открыл sources.list. Например, у меня есть sources.list, list и Untitled Document. Я думаю, что мой компьютер теперь не в состоянии узнать, к какому документу он относится, и я получаю ошибки, пытаясь загрузить R. Вы знаете, как исправить это, так что у меня есть […]

Не удалось найти пакет linux-kernel-devel

Я уверен, что есть еще три ссылки, которые сообщают о той же проблеме, я получаю Я следую этой ссылке, чтобы скомпилировать мое собственное ядро https://help.ubuntu.com/community/Kernel/Compile/ Инструменты, необходимые для запуска. Вам нужно будет установить несколько пакетов. Точные команды для установки этих пакетов зависят от того, какой выпуск вы используете: Харди (8.04): sudo apt-get install linux-kernel-devel fakeroot […]

Как я могу сохранить пакет, но отказаться от его конфигурации?

Я знаю, что могу использовать это, чтобы удалить пакет, но сохранить конфигурацию: sudo apt-get remove $package Я знаю, что я также могу использовать это, чтобы удалить пакет и отбросить его файлы конфигурации: sudo apt-get purge $package Но что, если я хочу сохранить пакет, но отказаться от его конфигурации? Контекст: я сделал что-то не так с […]

Как APT выбирает конкретный пакет для установки, чтобы предоставить виртуальный пакет, необходимый в качестве зависимости?

Например, awk – это виртуальный пакет, предоставляемый original-awk , mawk и gawk . Попытка установить его напрямую дает: Reading package lists… Done Building dependency tree Reading state information… Done Package awk is a virtual package provided by: original-awk:i386 2012-12-20-4 mawk:i386 1.3.3-17ubuntu2 gawk:i386 1:4.1.1+dfsg-1 original-awk 2012-12-20-4 mawk 1.3.3-17ubuntu2 gawk 1:4.1.1+dfsg-1 You should explicitly select one to […]

Проблемы с apt-get build-dep

Это часто случается со мной. Я иду, чтобы установить программу, и она говорит, что мне не хватает определенных зависимостей. Затем я запустил apt-get build-dep и получил сообщение об ошибке следующего вида: sudo apt-get build-dep gnome-shell Reading package lists… Done Building dependency tree Reading state information… Done The following packages have unmet dependencies: libgjs-dev: Depends: xulrunner-dev […]