Articles of упаковка

«Io: postinst-must-call-ldconfig» при создании пакета

Я пытаюсь создать пакет Ubuntu .deb для (довольно удивительного) языка Io . Я не разработчик этого языка, поэтому я еще не знаком с его исходным кодом . Это моя первая попытка создать файл .deb. Чтобы создать .deb, я следую этим инструкциям: http://www.webupd8.org/2010/01/how-to-create-deb-package-ubuntu-debian.html До сих пор мне удалось создать файл .deb (io_2010.06.01-1_amd64.deb) и файл изменений (io_201.06.01-1_amd64.changes). […]

Где / как я могу найти кого-нибудь, чтобы помочь мне упаковать приложение для Ubuntu в моей области?

Я хотел бы узнать, как упаковать приложение в PPA, доступное в исходном коде и лицензированном GPL. Я хотел бы узнать, как это сделать сам. Есть ли способ найти Ubunteros в моем районе, чтобы встретиться (Сан-Франциско – Сан-Хосе)?

Могу ли я использовать C ++ для написания исходного пакета для пакета .deb?

Какой язык программирования следует использовать для написания исходного пакета для пакета .deb? Я хочу упаковать программу на C ++.

Как установить Octave в Ubuntu 14.04 с помощью терминала

sudo apt-get build-dep octave не работает. Сообщение об ошибке E: Build-Depends dependency for octave cannot be satisfied because the package automake cannot be found Я изменил файл /etc/apt/sources.list с заменой deb-src на deb-src . Даже когда я пытаюсь sudo apt-get install octave , отображается ошибка, что пакет не находится. Изменить: я добавил строки deb-src в […]

Не удалось установить и запустить индикатор App / Panel в Ubuntu 14.04

Я разработал индикатор приложения для Ubuntu 14.04 с помощью Python. Я последовал этому руководству, и я смог успешно довести индикатор своего приложения до своего PPA. Когда я запускаю следующие команды – sudo add-apt-repository ppa:mayank26saxena/hn-indicator sudo apt-get update sudo apt-get install hn-indicator Индикатор приложения устанавливается успешно, но он автоматически не отображается в лотке уведомлений. Когда я […]

Разработка пакета Snap для проекта с использованием SDL2

В настоящее время я разрабатываю приложение, которое использует вход джойстика и генерирует различные волновые звуки с использованием SDL. Хотя реализация работает без каких-либо проблем, как только я упакую свое приложение с помощью snapcraft , мое приложение не может генерировать звуки и не вводить джойстик. Интерфейсы, которые использует мое приложение: x11 сеть PulseAudio сети связывания системы […]

Создание пакета из двоичных файлов – что случилось с моим управляющим файлом

Я занят попыткой создать пакет .deb из двоичных файлов моего приложения (не открытый источник), и у меня возникли проблемы с получением правильной информации для отображения в программном центре Ubuntu (когда вы нажимаете на файл .deb). См. Скриншот ниже файла управления и Software Center View. Похоже, что имя пакета и описание пакета обмениваются. Я ожидаю, что […]

Кто-нибудь предлагает услугу упаковочной оплаты для создания соответствующих пакетов и помещает их в ppa?

У нас есть приложение, предназначенное для работы в ubuntu, у которого есть гнездо завихряющихся зависимостей, все одинаковые. Мы дошли до того, что нам нужно создать пакет для этого, и мы находим наши навыки упаковки ubuntu, к сожалению, не до этой задачи. Есть ли служба, которая за плату, пакеты, готовит, выполняет необходимые резервы и помещает их […]

Какую версию Ubuntu я должен использовать, чтобы начать мой вклад в упаковку?

Я следую руководству MOTU о упаковке , есть примечание, что совет по работе с упаковкой в ​​текущей версии разработки (я запускаю 13.04) и для использования виртуальной машины. Я точно не знаю, какая версия текущей версии. Должен ли я использовать 13,04? благодаря

Какова цель пакета emacs24-common-non-dfsg?

Я попытался запустить Ch r из Emacs, но получил ошибку Информационный файл emacs не существует После googling я нашел пакет emacs24-common-non-dfsg . Какова цель этого пакета и почему я хочу его установить? Я использую Ubuntu 14.04.