Articles of пакет управления

Как удалить Adobe Reader?

Недавно я загрузил Adobe Reader для Linux со своего сайта и запускал его с помощью dpkg -i ….. Я действительно загрузил версию i386, а мой ноутбук – 64-битный. Затем он дал ошибку: система управления пакетами повреждена. Я искал этот сайт и исправил его с помощью sudo apt-get -f install . Затем был установлен Adobe Reader. […]

Как я могу избежать обновления?

Я отметил, что после установки первого огромного блока обновлений, который вы получите после новой установки, Unity 3D исчезнет, ​​оставив мне только 2D-поддержку. Поэтому, не зная, от чего это зависит, я решил отменить все обновления Unity-2D из списка. Проблема в том, что каждый раз, когда появляются новые обновления, те, с которыми я отчаянно пытаюсь избежать, всегда […]

Не удается chroot восстановить Ubuntu 64 бит

Я пытался получить пар для linux для работы с моей 64-битной системой Ubuntu 10.04 LTS. Я установил эти три (около 32-битных) пакетов: http://packages.ubuntu.com/quantal/libc-bin http://packages.ubuntu.com/quantal/libc6 http://packages.ubuntu.com/precise/libc6-i386 И теперь мой компьютер паникует при загрузке. Я попробовал chroot с компакт-диска Ubuntu 10.04 Live, используя следующие команды: mount /dev/sda1 /media/x mount –bind /sys /media/x/sys mount –bind /proc /media/x/proc mount […]

Список установленных пакетов, которые больше не устанавливаются через репозиторий?

Этот вопрос относится к другому вопросу, на который не ответил . Когда я обновил Ubuntu, все мои PPA были удалены (с которыми я в порядке). Есть ли способ перечислить все пакеты, у которых больше нет связанных с ними репозиториев?

dpkg и systemd: файл файла молча исчезает

Я пытаюсь упаковать своего самодельного демона в пакет debian. Я написал для .service файл .service systemd. Этот файл присутствует в пакете. Пакет устанавливается нормально. Но после установки в файле /etc/systemd/system отсутствует файл .service . При мониторинге /etc/systemd/system с inotifywait я вижу следующее: /etc/systemd/system/ CREATE myservice.service.dpkg-new /etc/systemd/system/ MODIFY myservice.service.dpkg-new /etc/systemd/system/ ATTRIB myservice.service.dpkg-new /etc/systemd/system/ ATTRIB myservice.service.dpkg-new /etc/systemd/system/ […]

Автоматическая установка PPA

После добавления некоторых PPA с Launchpad в мой repositiory ( add-apt-repository ) я хочу установить их автоматически. Насколько я знаю, нет никакой команды для установки всех новых PPA после apt-get update . И я не могу запустить скрипт, устанавливающий все новые PPA вручную, потому что имя установки некоторых PPA отличается от имени, которое они имеют […]

Как конвертировать deb-пакет в udeb

После того, как вы установите squid-deb-proxy-client через preseed / early_command , я хочу иметь udeb пакета squid-deb-proxy-client . Из чтения вики Debian кажется, что легко преобразовать обычный deb в udeb. Однако я не смог найти инструмент, который сделает это для меня. Поскольку я предполагаю, что мне также нужно преобразовать зависимости в udebs, я бы не […]

Не удается установить dsniff в 9.10 USB

Ubuntu 9.10 USB Pendrive работает хорошо даже после sudo apt-get update и я пытаюсь выполнить sudo apt-get install dsniff и я получаю следующее сообщение: ubuntu@ubuntu:~$ sudo apt-get install dsniff Reading package lists… Done Building dependency tree Reading state information… Done E: Couldn't find package dsniff Он не находит пакет по какой-то странной причине. Пожалуйста, помогите […]

являются ли специфические пакеты ubuntu для установки на lubuntu?

Я хочу переключиться на lubuntu 64 бит. Первоначально у меня был ubuntu 64 бит. Я сохранил все пакеты в / var / cache / apt / archive; Мой вопрос в том, что я могу использовать те же пакеты для lubuntu 64 бит и установить их через синаптический менеджер?

Ubuntu Upgrade разбивает firefox

Я обновил ubuntu, но обновление сломало firefox, adobe flash plugin и повредило базу данных пакета. Я запустил предлагаемый ремонт каталога, никаких изменений. Я запускал apt-get -f install , без изменений. Я запустил apt purge packageName, без изменений. Как я могу решить эту круговую зависимость? Вот несколько деталей: installArchives() failed: dpkg: dependency problems prevent configuration of […]