Articles of компиляция

Как установить Mono из источника?

Я пытаюсь установить Mono из источника (потому что в будущем мне нужно будет исправить ошибку). ПРОБЛЕМА: Скомпилированный Mono не ведет себя должным образом. Примечание: http://www.mono-project.com/Compiling_Mono_From_Git – не полный ответ. SparkleShare отлично работает на упакованном Mono Ubuntu, но я получаю TypeLoadException после выполнения инструкций на этой странице, поэтому некоторые параметры DLL или что-то тоже необходимо настроить […]

проблема с dcraw с fuji x raf

У меня есть ubuntu 12.04 lts 64 бит. Я не могу декодировать необработанный файл fuji fuji X с помощью утилиты dcraw (ошибка отчета: Corrupt data near 0xdc800) как доступная в «logithèque» dcraw 8.99-1build1. Это исправлено в новой версии этих утилит, я скомпилировал источник и установил новый dcraw, который отлично работает. Но dcraw используется напрямую или […]

Компиляция php 5.2 из источника в 12.04, apxs2 (через libtools) игнорирует -prefix, используемый с ./configure

В исходном каталоге: ./configure –prefix=/home/ashkan/Development/php/bin/php-5.2 –with-mysql –with-apxs2=/usr/bin/apxs2 make работает нормально, но make install говорит: Installing PHP SAPI module: apache2handler /usr/share/apache2/build/instdso.sh SH_LIBTOOL='/usr/share/apr-1.0/build/libtool' libphp5.la /usr/lib/apache2/modules /usr/share/apr-1.0/build/libtool –mode=install cp libphp5.la /usr/lib/apache2/modules/ libtool: install: cp .libs/libphp5.so /usr/lib/apache2/modules/libphp5.so cp: cannot create regular file `/usr/lib/apache2/modules/libphp5.so': Permission denied apxs:Error: Command failed with rc=65536 UPDATE: чтение man apxs2 кажется, что apxs компилируется, а […]

Попытка найти google / protobuf / compiler / parser.h

У нас есть приложение, которое в настоящее время работает на Fedora, которое мы пытаемся подключить к Xenial (16.04). Он использует заголовочный файл /usr/include/google/protobuf/compiler/parser.h что в мире Fedora мы находим в протобуф-девель rpm. Тем не менее, мы установили почти каждый apt, который мы можем найти вокруг protobuf, и он все еще не появился – любая идея, […]

Решить компиляцию файла ошибки PHP: ошибка: libXpm. (A | so) не найден

У меня возникла ошибка при компиляции PHP, я перечисляю детали ниже. Error configure error libxpm.(a so) not found Я проверил с dpkg -L libxpm-dev. он показывает, что необходимый файл находится в папке /usr/lib/x86_64-linux-gnu/ (libXpm.a). Я попытался использовать –with-xpm-dir=/usr/lib/x86_64-linux-gnu , но ошибка все еще существует.

Subversion 1.7 на 12.04: ошибка libsasl, компиляция из источника?

Предыстория: Я давний пользователь Gentoo, и это мой первый раз, когда Ubuntu (установленный на виртуальной машине, чтобы избежать компиляции всего с нуля). Я знаком с средой Linux, но немного не знаком с Ubuntu. Я пытаюсь установить Subversion 1.7 на Ubuntu и увидел это сообщение: Где я могу найти двоичный файл Subversion 1.7? В приведенной выше […]

Как исправить fglrx для установки на ядре 3.7rc7?

Для ошибки мне нужно проверить, все еще происходит ошибка в восходящем ядре 3.7rc7, и поскольку ошибка связана с fglrx, мне также необходимо установить более новую версию, которая работает с ядром 3.7. Как это сделать шаг за шагом?

Как просмотреть промежуточный код при компиляции программы на C?

Я хочу видеть промежуточный код, сгенерированный во время компиляции программы на языке C Используя флаг -S , создается код объекта, но есть ли что-либо, чтобы увидеть .i файлы, называемые промежуточным кодом.

как удалить httpd из источника

Я знаю сообщение: Как удалить apache, установленный с make install и использовать apache из репозиториев? , Я установил httpd2.4 из источника. Но для httpd2.4 нет make uninstall . Есть ли какие-либо простые способы очистки httpd2.4 встроенных и установленных из источника?

«Компилятор разбился с кодом: 1.« Сбой компиляции MonoDevelop 4

Я пытаюсь скомпилировать последнюю версию MonoDevelop (4.0.9) на моем Ubuntu 12.04, и я сталкиваюсь с ошибками, которые я не могу преодолеть. Вот конфигурации моей машины: OS: Ubuntu 12.04 64-bit Mono: version 3.0.12 И вот команды, которые я запускал для загрузки MonoDevelop: $ git clone git://github.com/mono/monodevelop.git $ cd monodevelop $ git submodule init $ git submodule […]