Articles of управление пакетами

Удаление idle-python2.7 в Ubuntu 12.04

У меня возникают некоторые проблемы при обновлении пакетов на Ubuntu 12.04: Processing triggers for menu … Errors were encountered while processing: idle-python2.7 Setting up idle-python2.7 (2.7.3-0ubuntu3.5) … Traceback (most recent call last): File "/usr/lib/python2.7/compileall.py", line 16, in <module> import struct File "/usr/lib/python2.7/struct.py", line 1, in <module> from _struct import * ImportError: No module named _struct […]

неудовлетворительные зависимости и неисправность count> 0

Я попытался установить fbreader, следуя всем шагам, но в итоге оказались неудовлетворенными зависимостями, я также думаю, что файл ссылается в двух местах одновременно и, следовательно, убивает его. любые идеи, как я могу это исправить? я сделал много исследований и пытался: simon@simon-Studio-1558:~$ sudo apt-get -f install Reading package lists… Done Building dependency tree Reading state information… […]

Земля Google не будет переустанавливаться

Я пытался выполнить исправление, найденное по этой ссылке http://www.omgubuntu.co.uk/2012/01/how-to-make-google-earth-look-native-in-ubuntu Он требует, чтобы вы удалили определенные файлы из папки / opt / google / earth / free, а затем добавили новые, которые вы загружаете. Я удалил файлы, но ссылки для загрузки новых были непригодными. Я использовал gksudo nautilus поэтому мусор был отключен, что я не смог […]

Каков наилучший способ установки R-пакета XLConnect?

Каков наилучший способ установки R-пакета XLConnect в Ubuntu 12.04 x86? Я попытался вручную установить его через R, используя install.packages("XLConnect",dependencies=TRUE) , но через полчаса компиляции, когда я попытался загрузить его, я получил эту ошибку: > require(XLConnect) Loading required package: XLConnect Warning message: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, : there is […]

Сломанные пакеты Mysql

Я не могу исправить сломанные пакеты на моей машине ubuntu. Я следовал за многими командами, размещенными на форумах. Ничего не произошло! Пакеты, в которых есть проблема: mysql-server-5.5 mysql-server Любой способ разрешить это? Конфигурация моего компьютера на греческом языке, и я не могу дать вам полезный результат, так как эта проблема мешает мне менять язык консоли! […]

Что такое ядро ​​и как удалить неиспользуемые ядра?

У меня есть ubuntu 12.04 lts. Я новичок в ubuntu, и я получаю это предупреждение, что на томе / загрузке осталось 0 байт. я задал вопрос: это ссылка на него Поэтому я ответил, что должен удалить неиспользуемые ядра. Может ли кто-нибудь объяснить мне простым языком, что такое ядро, и как удалить неиспользуемые ядра. Спасибо 🙂

grive-tools: Зависит от libcurl4-openssl-dev, но он не будет установлен

недавно я попытался установить Grive Tools, следуя инструкциям с этого сайта Ubuntu Google Drive Client с Grive и Grive Tools . Все работало идеально, пока я не дошел до того, что применил команду sudo apt-get install grive-tools . Появилась следующая ошибка: grive-tools : Depends: libcurl4-openssl-dev but it is not going to be installed Я много […]

Почему утилита mkpasswd входит в пакет whois?

Утилита mkpasswd присутствует во многих Linux-системах как часть базовой установки. В Ubuntu 12.04 по какой-то неизвестной причине он, похоже, входит в пакет «whois». Помимо «исторических причин», есть ли причина для этого, казалось бы, произвольного включения?

Новое программное обеспечение не может быть установлено, так как существует проблема с установленным в данный момент программным обеспечением. Вы хотите восстановить эту проблему сейчас?

Это детали, которые я получаю, когда операция пакета завершается с ошибкой, если я нажму ремонт: installArchives () не удалось: E: Не удается получить версию debconf. Установлен ли debconf? debconf: apt-extracttemplates не удалось: нет такого файла или каталога E: Невозможно получить версию debconf. Установлен ли debconf? debconf: apt-extracttemplates не удалось: нет такого файла или каталога E: […]

Невозможно установить некоторые пакеты. Зависит: x, но x должен быть установлен

Я на 64-битной системе, вот что я подозреваю в создании этой проблемы. Я пытаюсь установить различные пакеты, один из них – libssl-dev . $ sudo apt-get install libssl-dev Reading package lists… Done Building dependency tree Reading state information… Done Some packages could not be installed. This may mean that you have requested an impossible situation […]