Articles of cmake

Почему он все еще жалуется на libcurl.so.4?

Я ввожу curl из / usr / bin / curl в / usr / local / bin / curl. Когда я запускаю из командной строки, «нет информации о версии недоступно», но когда я компилирую ее в домашней среде, она все еще жалуется на это: cmake: ~ / local / lib / libcurl.so.4: информация о версии […]

Форсировать компиляцию с qt4, даже если qt5 установлен

Я на Ubuntu 14.04 и у меня установлены как qt4, так и qt5 (из репозиториев). Я думал, что могу переключаться между зданием с qt5 на построение с qt4 просто с помощью sudo apt-get install qt4-default Но программа по-прежнему построена с Qt5 и дает ошибку, потому что она поддерживает только Qt4. Я проверил версию qmake и […]

Разница между -pthread и -pthreads для C / C ++ на Ubuntu 14.04

В настоящее время я пытаюсь скомпилировать https://github.com/OpenKinect/libfreenect на Ubuntu 14.04 LTS, но он не работает. В журналах CMake я вижу ошибки в отношении библиотеки «-pthreads», которая не найдена, но находит «-pthread» без проблем. В чем разница между ними? Есть ли какой-либо конкретный пакет для -pthreads на Ubuntu?

CMake не может найти нужную библиотеку GoogleTest в Ubuntu

Аналогичный вопрос здесь . Это мой CMakeLists.txt: cmake_minimum_required(VERSION 2.6) # Locate GTest find_package(GTest REQUIRED) include_directories(${GTEST_INCLUDE_DIRS}) # Add test cpp file add_executable(foo foo.cpp) # Link test executable against gtest & gtest_main target_link_libraries(foo ${GTEST_LIBRARIES} ${GTEST_MAIN_LIBRARIES} pthread) И мой foo.cpp: #include TEST(sample_test_case, sample_test) { EXPECT_EQ(1, 1); } int main(int argc, char **argv) { testing::InitGoogleTest(&argc, argv); return RUN_ALL_TESTS(); } […]

Не удается найти общую библиотеку в том же каталоге, что и CMakeLists.txt

В моем каталоге исходного кода у меня есть файл общей библиотеки libAlpha.so . Затем в моем файле CMakeLists.txt у меня есть: target_link_libraries(MyProgram Alpha) Однако это дает мне ошибку: usr/bin/ld: cannot find -lAlpha Если я переименую файл библиотеки в Alpha.so или lAlpha.so , то получаю ту же ошибку. Аналогично, если я вместо этого использую строку: target_link_libraries(MyProgram […]

Компиляция проекта на основе OpenCV и ROS в Ubuntu

Я получаю сообщение об ошибке при запуске CMake (на самом деле rosmake) в моем проекте. Я уже установил OpenCV, но я получаю следующую ошибку: Linking CXX shared library ../lib/libCornerHelper.so /usr/bin/ld: cannot find -lopencv_contrib /usr/bin/ld: cannot find -lopencv_legacy /usr/bin/ld: cannot find -lopencv_stitching /usr/bin/ld: cannot find -lopencv_gpu /usr/bin/ld: cannot find -lopencv_objdetect /usr/bin/ld: cannot find -lopencv_calib3d /usr/bin/ld: cannot […]

Как установить Avogadro из источника после получения ошибки ниже?

Следующий вывод выходит из команды cmake source-directory когда я был в другом каталоге для компиляции. — The build type is Release — Found lupdate: /usr/bin/lupdate-qt4 — Found lrelease: /usr/bin/lrelease-qt4 CMake Warning at CMakeLists.txt:230 (message): Qt4 Linguist not found, please install it if you want Avogadro translations — checking for module 'openbabel-2.0>=2.3.0' — found openbabel-2.0, version […]

Msgstr "Не указан исполняемый файл." Ubuntu SDK Unity8

Работала вчера вечером, но сегодня, когда я снова начал, я не смог запустить unit8 из QtCreator / UbuntuSDK. После создания и запуска в нем просто говорится: «Нет исполняемого файла». FYI; Это ветвь, которую я импортировал из lp: unity8 в QtCreator. Никаких изменений не было сделано Где и как указать исполняемый файл?

Добавить внешнюю библиотеку в приложение Ubuntu в SDK Ubuntu

Я пытаюсь добавить библиотеку QuaZip в свой проект ( https://launchpad.net/vadetux ). Я попытался установить переменную EXEC в CMakeLists.txt, чтобы: set(EXEC "qmlscene -I /usr/include/quazip $@ ${VADETUX-ES-ES_DIR}/${MAIN_QML}") а также: set(EXEC "qmlscene -I ${QUAZIP_IMPORT_DIR} $@ ${VADETUX-ES-ES_DIR}/${MAIN_QML}") это QUAZIP_IMPORT_DIR, эквивалентный / usr / lib / $ {ARCH_TRIPLET} (x86_64-linux-gnu в моем случае), где находятся файлы libquazip.so/a. В любом случае, я […]

После обновления до 15.10 мои проекты областей не могут быть построены для инструмента единства. Msgstr "ошибка: версия g ++ должна быть 4.9!"

Недавно я обновился до Ubuntu 15.10. Я занимаюсь областями, и многие из моих проектов в облаках перестали строиться после обновления. Мой рабочий процесс состоит из запуска областей сначала в инструменте единства-области. Ошибка в SDK Ubuntu показывает: CMakeLists.txt:12: error: g++ version must be 4.9! :-1: error: [cmake_check_build_system] Error 1 Строки 8-14 в CMakeLists.txt читаются: # We […]