Articles of cuda

Ошибка кросс-компиляции CUDA! Сообщение об ошибке cuda-gdb RSEG1058

Я новичок в этом CUDA и персонале параллельных вычислений, и у меня есть недавняя проблема. У меня есть система Ubuntu 12.04, которая является хостом и Jetson TK1 в качестве цели. Я использую Nsight Eclipse для написания, редактирования и компиляции алгоритмов. Я использую протокол SSH для подключения TK1 от главного компьютера. Когда я пытаюсь выполнить некоторые […]

Проблемы при запуске deviceQuery Cuda SDK

Вчера я собрал примеры sdk, и я тоже немного их запускал. Но сегодня я пытаюсь запустить deviceQuery и в папке ~ / NVIDIA_GPU_Computing_SDK / C / bin / linux / release, выпустив команду ./deviceQuery, и он показывает: ./deviceQuery: error while loading shared libraries: libcudart.so.4: cannot open shared object file: No such file or directory Может […]

Ошибка при запуске образца CUDA после установки cuda 8.0

Я установил cuba8.0 на ubuntu 16, выполнив следующие шаги: http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#axzz4aZ4Q3q7v Затем выполните измерение подтверждения. После этого я запускаю make и bump в erros, как показано ниже. $ делают … Предупреждение nvcc: Архитектуры ‘compute_20’, ‘sm_20’ и ‘sm_21’ устарели и могут быть удалены в будущей версии (используйте -Wno-deprecated-gpu-target для предупреждения). / usr / bin / ld: не […]

Какова правильная версия CUDA для моего драйвера nvidia?

Я использую ubuntu 14.04. Я хочу установить CUDA. Но я не знаю, какая версия подходит для моего ноутбука. Я отслеживаю свой диск, который $cat /proc/driver/nvidia/version NVRM version: NVIDIA UNIX x86_64 Kernel Module 304.125 Mon Dec 1 19:58:28 PST 2014 GCC version: gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1) Я попытался установить CUDA cuda-linux64-rel-7.0.28-19326674 но когда я тестирую […]

ubuntu 14.04.4 с ядром 4.2: черный экран вместо экрана входа в систему после установки драйвера nvidia

Я новичок в ubuntu, и я хочу установить cuda 7.5 на свой компьютер, но я столкнулся с проблемами, когда пытался установить драйвер nvidia. Я пробовал много раз и много методов, все провалилось. Например, я попробовал: sudo apt-get purge nvidia* sudo add-apt-repository ppa:graphics-drivers/ppa sudo apt-get update sudo apt-get install nvidia-361 Но вместо экрана входа я получил […]

Могу ли я менять карты Nvidia без необходимости перенастроить драйверы?

В настоящее время работает Ubuntu 14.04.1 LTS на моем рабочем столе с GTX 650 ** с драйверами версии 352.63, CUDA 7.5, cuDNN, Digits, Tensorflow. Я хотел бы получить карту GTX 1060. Будет ли это просто вопрос о том, чтобы отключиться, обменять карты и снова загрузиться; водитель узнает карточку?

nvcc не найден, но только при использовании sudo

Я не могу заставить НИЧЕГО работать на Linux. Я пытаюсь скомпилировать CudaMiner . Производительность sudo make : ypt-jane.o `test -f 'scrypt-jane.cpp' || echo './'`scrypt-jane.cpp mv -f .deps/cudaminer-scrypt-jane.Tpo .deps/cudaminer-scrypt-jane.Po nvcc -g -O2 -Xptxas "-abi=no -v" -arch=compute_10 –maxrregcount=64 –ptxas-options=-v -I./compat/jansson -o salsa_kernel.o -c salsa_kernel.cu /bin/bash: nvcc: command not found make[2]: *** [salsa_kernel.o] Error 127 make[2]: Leaving directory […]

Могу ли я установить CUDA 5.0 на Ubuntu 14.04?

Я сейчас на Ubuntu 14.04 и требую CUDA 5.0. Однако, похоже, CUDA 5.0 доступен только для Ubuntu 10.04 и 11.10 на основе страницы загрузки: https://developer.nvidia.com/cuda-toolkit-50-archive Мне интересно, загружу ли CUDA 5.0 для Ubuntu 10.04, будет ли работать на моем Ubuntu 14.04? Или не возможно иметь CUDA 5.0 с Ubuntu 14.04? Большое спасибо

Как вы выбираете графический драйвер в безголовой коробке?

Я настраиваю экземпляр GPU EC2 для экспериментов с программированием CUDA с использованием UI Ubuntu 14.04 AMI. Я установил драйверы nvidia, указанные основной версией на странице загрузки Nvidia для Grid K520 (340) из PPA xorg-edgers. ubuntu-drivers devices показывают, что это рекомендуемая версия. Однако lspci -vnn | grep -i VGA -A 12 lspci -vnn | grep -i […]

CUDA: для версии CUDA недостаточно версии драйвера

При запуске примера CUDA /usr/local/cuda/samples/1_Utilities/deviceQuery$ с помощью команды sudo ./deviceQuery выход был: ./deviceQuery Starting… CUDA Device Query (Runtime API) version (CUDART static linking) cudaGetDeviceCount returned 35 -> CUDA driver version is insufficient for CUDA runtime version Result = FAIL Об использовании lspci -v | grep -i Команда lspci -v | grep -i : NVIDIA Corporation […]