Articles of matplotlib

Установка matplotlib vn 1.2 и Basemap на Ubuntu

Я пытаюсь установить vn 1.2 Matplotlib на моем компьютере Ubuntu, чтобы я мог использовать некоторые из функций анимации. Крайне важно также, чтобы Basemap. Единственный способ, которым я нашел импортировать Basemap, – это apt-get. Я могу установить matplotlib 1.2 загрузки по-разному – используя pip, apt-get и из исходного кода, но независимо от того, что я делаю, […]

Проблема Импорт Pylab в Python 2.6

Я использую Python 2.6 в Ubuntu 10.10. Я запустил help(“modules”) в интерпретаторе Python и pylab и matplotlib. Однако, когда я запускаю import pylab , я получаю следующее сообщение об ошибке. >>> import pylab Traceback (most recent call last): File “”, line 1, in File “/usr/lib/pymodules/python2.6/pylab.py”, line 1, in from matplotlib.pylab import * File “/usr/lib/pymodules/python2.6/matplotlib/pylab.py”, line […]

получил «libatk-1.0.so.0: undefined symbol», когда я попробовал ipython -pylab в Ubuntu 13.10

В настоящее время я использую Ubuntu 13.10 и применяю все обновления системы. Я установил Enthought Canopy (Версия: 1.1.1.1452). И сегодня, когда я попытался заговорить, я ничего не получил. После googling я запустил «ipython -pylab» в командной строке, но получил следующее сообщение: Matplotlib backend_wx and backend_wxagg require wxPython >=2.8 Я мог бы попасть в интерактивную оболочку […]

Почему Ubuntu не устанавливает matplotlib для моей правильной версии python?

Когда я пишу, в which python я получаю /usr/bin/python как и ожидалось. Тем не менее, я хотел установить matplotlib и запустить sudo apt-get install python-matplotlib Reading package lists… Done Building dependency tree Reading state information… Done python-matplotlib is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded. Достаточно […]

Как установить более раннюю версию matplotlib?

У меня есть matplotlib 1.3.1, установленный на моем компьютере. Однако мне нужно запустить код, который работает с matplotlib 1.1.1, но не с 1.3.1. Поэтому я должен удалить эту версию и установить 1.1.1. Как это возможно, не нарушая мою установку python или что-то еще ? И, кроме того, как я запрещаю компьютеру обновлять эту библиотеку? У […]

Обновление Ubuntu 14.04 вызывает ошибку matplotlib

Начиная с обновления до 14.04 любой запущенный код python, который использует matplotlib, возвращает ошибку. Вот что возвращает моя консоль ipython In [1]: import matplotlib.pyplot as plt ————————————————————————— RuntimeError Traceback (most recent call last) RuntimeError: module compiled against API version 9 but this version of numpy is 6 ————————————————————————— ImportError Traceback (most recent call last) <ipython-input-1-eff513f636fd> […]

Как гарантировать, что matplotlib в виртуальной машине Python 3 использует бэкэнд TkAgg?

Я использую Ubuntu 16.04 с Python 3. Используя APT для установки python3-matplotlib а затем распечатывая бэкенд TKAgg , вы TKAgg , что ожидается, потому что Ubuntu имеет 16.04 установлен python3-tk . Это делается путем запуска: sudo apt install python3-matplotlib python3 -c 'import matplotlib as mpl; print(mpl.get_backend())' Однако, если я создаю virtualenv для Python 3, активируйте […]

Не удалось установить matplotlib с помощью pip в Ubuntu 16.04

В Ubuntu 16.04 я могу установить почти каждый пакет и библиотеку python, используя pip, за исключением matplotlib. Я использую эту команду для установки matplotlib pip install matplotlib Это дает ошибку: Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-z5w80J/matplotlib/ Но я не воспринимаю эту ошибку при установке любого другого пакета python, и я […]

Как установить Python Matplotlib 1.5.1 на Ubuntu?

Я хочу установить matplotlib 1.5.1 для python 3.4 на Ubuntu 14.04. Но, когда я sudo apt-get install python3-matplotlib терминал sudo apt-get install python3-matplotlib , я просто получаю matplotlib 1.3.1. Я попытался использовать pip для установки matplotlib, но я получил некоторые ошибки, которые нелегко было решить. Есть ли простой способ установить matplotlib 1.5.1 на Ubuntu?

Нет модуля с именем 'numpy'

На самом деле я перехожу от Windows к Linux. Используя pycharm в Windows, у меня есть сценарий python 3, который требует запуска numpy и matplotlib, поэтому я установил их в свою систему Linux, используя sudo apt-get install python3-numpy sudo apt-get install matplotlib3-numpy Но все же, когда я пытаюсь запустить скрипт, я получаю ошибку: from python3-numpy […]