Articles of package management

E: Не удалось найти пакет nepomuk-core-dev

Я установил Ubuntu 12.04, и я хочу установить nepomuk-core-dev , чтобы создать плазменный медиацентр ( http://sinny.in/node/25 ), но я получаю следующую ошибку: vijay13@ubuntu:~/plasma-mediacenter/build$ sudo apt-get install nepomuk-core-devReading package lists… Done Building dependency tree Reading state information… Done E: Unable to locate package nepomuk-core-dev and following error while building : — Found KDE4Workspace: /usr/lib/cmake/KDE4Workspace/KDE4WorkspaceConfig.cmake CMake Error […]

Ubuntu, какие бесплатные пакеты инструментов доступны для создания профессиональных макетов программного обеспечения?

Например: http://www.balsamiq.com/ для Linux есть ли какие-либо профессиональные быстродействующие макеты? (а не ручку и бумагу, мы знаем, что мы делаем это в основном, но она должна быть быстрой и профессиональной для совместного использования, а не с точки зрения открытой офисной точки или gimp или с флэш-памятью macromedia). Что-то специально предназначено для Linux в смысле создания […]

Как всегда устанавливать предлагаемые пакеты с apt-get?

Я читал в этом посте о том, как устанавливать предлагаемые пакеты. Я получаю, как это сделать с помощью apt-get install whatever-package-name –install-suggests . Но я прочитал, что вы можете сделать файл в /etc/apt/apt.conf.d/ и поставить в строку APT::Install-Suggests "true" . Но я не понимаю, какой тип файла делать. PS Если я полностью не в базе, […]

Как установить xxdiff в 13.04?

пакет xxdiff, кажется, пропал без вести в Raring Ringtail. Кто-нибудь знает, в чем проблема / как вернуть его?

Моя система разбита, я думаю – проблемы с libqt4-test

Итак, вот в чем проблема: каждый раз, когда я пытаюсь установить пакет, я получаю сообщение об ошибке: Reading package lists… Done Building dependency tree Reading state information… Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: libqt4-test : Breaks: libqt4-test:i386 (!= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.2 is to […]

Ошибка сломанного счета> 0

Я запускаю Ubuntu 11.10 . У меня есть это сообщение об ошибке, которое отображается как знак отсутствия, такой как этот . Я прочитал следующие вопросы на форуме: Сломанный пакет после обновления: linux-headers, error brokencount> 0 Зависимости не встречались 12.04? дублировать Сломанный пакет после обновления: linux-headers, error broken count> 0 Однако это указывает на то, что […]

Почему я не могу установить эти пакеты?

Я хочу установить библиотеку curl в ubuntu 12.04 LTS. Для этого я использую следующую команду: sudo apt-get install libcurl4-openssl-dev. но я получил ошибки как ajay@ajay-K54L:~$ sudo apt-get install libcurl4-openssl-dev [sudo] password for ajay: Reading package lists… Done Building dependency tree Reading state information… Done Some packages could not be installed. This may mean that you […]

«Не удалось найти« исполняемый файл ». После apt-get install / remove

Я получаю это сообщение (не могу найти «исполняемый файл.) В терминале после использования sudo apt-get, так как я установил и удалил Krusader. Я использую Ubuntu 12.10 с Unity. $ sudo apt-get remove gstm Reading package lists… Done Building dependency tree Reading state information… Done The following packages will be REMOVED: gstm 0 upgraded, 0 newly […]

Как я могу указать языки, которые apt-get использует?

В какой-то момент моей установки я должен был выбрать несколько языков по умолчанию. Когда я запускаю sudo apt-get update , я получил результат, похожий на следующий. Ign http://ppa.launchpad.net quantal/main Translation-en_NZ Ign http://ppa.launchpad.net quantal/main Translation-en_GB Ign http://ppa.launchpad.net quantal/main Translation-en_CA Ign http://ppa.launchpad.net quantal/main Translation-en_AU Ign http://ppa.launchpad.net quantal/main Translation-en Я хочу сделать apt-get только поиск en_AU , en_GB […]

Отвечая на вопросы debconf из пользовательского графического интерфейса в Python? (Пользовательский интерфейс)

Я пишу приложение, которое должно позволить пользователю устанавливать некоторые дополнительные пакеты, когда это необходимо. Я хотел бы создать пользовательский графический интерфейс, который собирает вопросы debconf пакетов вместе с некоторыми другими вопросами из моего приложения. Затем я установил пакет с помощью aptd или что-то еще, и на все вопросы, заданные с помощью скрипта установки пакета, будут […]