Articles of qt5

QT: qmake не распознает 3dcore, 3drender

Я использую qmake для компиляции моего проекта QT . В моем файле .pro меня есть строка: QT += 3dcore 3drender 3dinput 3dextras При выполнении qmake myprofile.pro я получаю ошибку: Project ERROR: Unknown module(s) in QT: 3dcore 3drender 3dinput 3dextras Я использую Ubuntu17 и имею QT5 . Как я могу заставить его работать с qmake ? […]

Драйвер Qmysql не загружен, но доступен

Я хочу связать свою базу данных (mysql) с библиотекой Qt на ubuntu 16.04. Но я столкнулся с этой ошибкой: QSqlDatabase: QMYSQL driver not loaded QSqlDatabase: available drivers: QSQLITE QMYSQL QMYSQL3 QPSQL QPSQL7 Результатом ldd /Qt-PATH/Qt5.7.0/5.7/gcc_64/plugins/sqldrivers/libqsqlmysql.so является: linux-vdso.so.1 => (0x00007fff9d55a000) libmysqlclient_r.so.16 => not found libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007efc887eb000) libcrypt.so.1 => /lib/x86_64-linux-gnu/libcrypt.so.1 (0x00007efc885b3000) libnsl.so.1 => /lib/x86_64-linux-gnu/libnsl.so.1 (0x00007efc8839a000) […]

Окно QT Ubuntu активно, но невидимо

Рабочий код переместился из Qt4 Debian в Qt 5.5.1 Ubuntu 16.04.2. Передача была без проблем до одной серьезной проблемы (возможная ошибка в Qt или Ubuntu). objective состоит в том, чтобы открыть второе окно из MainWindow. Опять же, работает без проблем в Qt4, но Qt5 второе окно создается и присутствует, но невидимо. Предыдущий экран полностью виден […]

ListView Подзаголовок делегата, размер значка и обложка заголовка слов?

Я работаю над мобильным приложением ubuntu, и у меня есть несколько вопросов по настройке списка. Список может содержать значок, но будет иметь заголовок и субтитры. У меня возникают проблемы с тем, что эскиз вытягивается из Интернета, и я хочу ограничить его высоту и ширину. Кроме того, заголовок не обертывается, если он слишком длинный, а просто […]

Qt5 с Qt 4.7 на Ubuntu 13.04. Как установить его без конфликтов?

Я использую Qt5 и теперь нуждаюсь в Qt 4.7 (для встроенного устройства). Возможно ли установить его дополнительно на Ubuntu 13.04?

Поддерживаемые Qt 5.4 файлы .so имеют стандартный Ubuntu 14.04 LTS Trusty или нет

Я могу сделать deb файл приложения Qt 5.2.1, но не приложение Qt 5.4 в Ubuntu 14.04 LTS, 64 бит. Я видел, что файлы Qt .so, представленные на пути /usr/lib/x86_64-linux-gnu/ , совместимы с Qt 5.2.1, а не совместимы с Qt 5.4. Поэтому я просто хочу знать, какие версии совместимых с Qt версий .so имеют стандартный Ubuntu […]

Изменить тему QT5

Я использую i3wm на Ubuntu 15.10. Мне было интересно, как изменить тему QT5? Со старым QT4 его можно было изменить с помощью qt4-config. Однако пока нет qt5-config. Я пробовал использовать qt-config-tool, но он запускается при запуске. Существует также lxqt-config, но он находится только в xenial репозиториях, и мне это нужно для willy. Итак, есть ли […]

Установка Qt 5.x на Ubuntu по всему миру

Всем привет! 🙂 Мне нужно установить Qt 5 по всему миру на Ubuntu, чтобы иметь возможность использовать QML-библиотеки, такие как Kirigami. Однако большинство результатов поиска Google показывают, как установить его локально (как папку) с официального сайта Qt. Как установить Qt 5.x в виде набора пакетов, чтобы получить что-то функционально эквивалентное Qt-установке из qt.io ? Я […]

QtQuick не найден (Lubuntu)

На новой установке Lubuntu 13.04 я установил Qt5 из официальных репозиториев ubuntu. Но эта установка Qt5 не может найти модуль QtQuick. Что мне не хватает? qmlscene test.qml test.qml: import QtQuick 2.0 Rectangle { } Вывод: file: ///home/…/test.qml: 1 модуль «QtQuick» не установлен Я уже дважды проверял, установлены ли следующие пакеты: $ dpkg –get-selections | grep […]

Zeal из PPA имеет неудовлетворенные зависимости

Я пытаюсь установить Zeal через ppa в Ubuntu 13.04, но дает ошибку: The following packages have unmet dependencies: zeal : Depends: libqt5core5 (>= 5.0.2) but 5.0.1+dfsg-0ubuntu4.1 is to be installed Depends: libqt5gui5 (>= 5.0.2) but 5.0.1+dfsg-0ubuntu4.1 is to be installed Depends: libqt5network5 (>= 5.0.2) but 5.0.1+dfsg-0ubuntu4.1 is to be installed Depends: libqt5sql5 (>= 5.0.2) but […]

Intereting Posts
Что мне нужно сделать, чтобы переключиться с Ubuntu на Lubuntu на компьютер с двойной загрузкой? Как можно загрузить веб-страницу с php как простой html? Ошибки, возникающие при установке kubuntu на 15.04 Как автоматически установить всю коллекцию Google Web Fonts? установить пакет из определенных дистрибутивов с приватным хранилищем apt? Я хочу поделиться своим «/» в самбе. Как сделать его доступным для редактирования в сети Windows? Будьте в курсе Rhythmbox? Отображения Gnome-terminal + Vim и CTRL-Shift Безопасно удалить / usr / src / linux-заголовки после очистки старых изображений Linux? Ubuntu 13.10 – Черный экран после входа в систему после установки драйверов nVidia установить gnome-shell на ubuntu 16.04 проблема монтирования в ubuntu 12.10 Как выбрать, на каком мониторе YouTube полноэкранные? Двойные окна загрузки 8 – ubuntu; обновление до окон 10 Беспроводная связь с беспроводным адаптером Atheros от AR242x / AR542x не работает на Acer Aspire One ZG8